continuous pronounced flickering when loading and scrolling in 7.0 (thunderbird and firefox)

RESOLVED DUPLICATE of bug 657401

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 657401
6 years ago
4 years ago

People

(Reporter: al_9x, Unassigned)

Tracking

7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Fx 7.0b3, TB 6.0b1, ok in 6.0

This happens intermittently in Fx, but with TB I can repro reliably in a new profile with "Get Addons" page.  In TB it also happens in the extension list, which is XUL, I believe.  Resizing the window makes the flickering stop.  The exact nature of the flicker is: every time the wheel is turned and the page scrolls, the scrolling content are briefly goes blank.

1. xp sp3
2. start TB 7.0b1 with a new profile (-profile <non existent folder>), don't create any accounts
3. open the add-on manager, the get add-ons page opens
4. wheel scroll the page, it flickers
5. either resizing or minimizing and restoring the window, removes the flicker
6. on subsequent loads of "get add-ons" after a restart, the flicker doesn't always happen, but if you clear the cache, it comes back
(Reporter)

Comment 1

6 years ago
(In reply to al_9x from comment #0)
> the scrolling content are briefly goes blank.

typo: scrolling content area

> but if you clear the cache, it comes back

1. close add-on manager
2. restart
3. clear cache
4. open add-on manager

the above sequence is as reliable for me as starting with a new profile each time
(Reporter)

Updated

6 years ago
Summary: intermittent flickering when mouse wheel scrolling in 7.0 (thunderbird and firefox) → flickering when mouse wheel scrolling in 7.0 (thunderbird and firefox)
(Reporter)

Comment 2

6 years ago
Focusing on TB for now, since it's easier to repro

This seems to have been fixed in 8.0, ran mozregression on TB:

Last good nightly: 2011-08-12 <- bug present, flicker
First bad nightly: 2011-08-14 <- bug fixed, no flicker

Pushlog:
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=8f7fe249332e&tochange=b76dac043e0f

However I am not sure mozregression is reporting the pushlog correctly, buidconfig of the two builds reports:

http://hg.mozilla.org/mozilla-central/rev/f262c389193e
http://hg.mozilla.org/mozilla-central/rev/145c98d55ae1

which would make the pushlog:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f262c389193e&tochange=145c98d55ae1

Is that correct?
There are several changes in that last range that might have affected this (bug 657401 most obviously, but also bug 386444 and bug 677095).
(Reporter)

Comment 4

6 years ago
Just want to be sure, is http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f262c389193e&tochange=145c98d55ae1 the right pushlog, i.e. is mozregression is wrong?

What needs to happen for this to be fixed in 7.0?  This scroll flicker is very unpleasant, is a regression and is already fixed, seems like a good candidate for backporting.
That pushlog seems a lot more likely than the other.

To get this fixed for 7.0 at this point, you'd probably need a time machine.  If, as I suspect, this was fixed by bug 657401, there's some backporting discussion in that already that suggests it won't be backported.
(Reporter)

Comment 6

6 years ago
Created attachment 557779 [details]
flicker in the TB get add-ons page when loading, mousing over, scrolling

(In reply to Boris Zbarsky (:bz) from comment #5)
> That pushlog seems a lot more likely than the other.
> 
> To get this fixed for 7.0 at this point, you'd probably need a time machine.
> If, as I suspect, this was fixed by bug 657401, there's some backporting
> discussion in that already that suggests it won't be backported.

Bug 657401 was considered minor because there was only a single flicker when approaching the top while scrolling up.  What I am reporting is far more serious, continuous pronounced flickering while loading, mousing over certain elements and scrolling.  How can you release 7.0 (TB & Fx) in such a state?  The impression one gets is of an alpha quality release with major problems.  What's the point of a beta if such bugs are not fixed?

Attaching a screencap, playable with WMP and mplayer.  Towards the end, for contrast I resize the window which gets rid of the flicker and you see normal scrolling.

This also happens if Fx, in fact just happened with this very page when I opened it from a link in an email.  But I can't repro consistently in Fx.
I would suggest putting those comments in bug 657401, assuming that's what fixed the problem for you.

If you want to verify that, please tell me which OS you want builds for and I can probably run a pair of try builds before/after the fix for that bug for you to test.
(Reporter)

Comment 8

6 years ago
(In reply to Boris Zbarsky (:bz) from comment #7)
> I would suggest putting those comments in bug 657401, assuming that's what
> fixed the problem for you.
> 
> If you want to verify that, please tell me which OS you want builds for and
> I can probably run a pair of try builds before/after the fix for that bug
> for you to test.

Yes I definitely want to identify the fix.  I would need a windows (x86 xp) TB build.

Thanks.
Hmm.  TB is a pain in my case.  Can you make use of Firefox builds?
(Reporter)

Updated

6 years ago
Summary: flickering when mouse wheel scrolling in 7.0 (thunderbird and firefox) → continuous pronounced flickering when loading and scrolling in 7.0 (thunderbird and firefox)
(Reporter)

Comment 10

6 years ago
(In reply to Boris Zbarsky (:bz) from comment #9)
> Hmm.  TB is a pain in my case.  Can you make use of Firefox builds?

I can't repro reliably in Fx, it just sometimes happens and I don't know how to trigger it.  I do need a TB build.
(Reporter)

Comment 11

6 years ago
(In reply to al_9x from comment #0)
> Fx 7.0b3, TB 6.0b1, ok in 6.0

TB 7.0b1
(Reporter)

Comment 12

6 years ago
(In reply to Boris Zbarsky (:bz) from comment #9)
> Hmm.  TB is a pain in my case.  Can you make use of Firefox builds?

Any chance you could make a tb build?
I'll see what I can do.  It's a huge pain to do TB builds against different m-c changesets via try...  For one thing it involves me pulling a TB tree.
I tried pushing http://hg.mozilla.org/try-comm-central/rev/313befec3cc4 and http://hg.mozilla.org/try-comm-central/rev/878b57fa4484 with and without the patch for bug 657401 respectively, but the former is claiming it can't pull comm-central and the latter is just saying nothing.  And in both cases tbpl is telling me nothing about the status.

I strongly suggest finding someone who actually works on Thunderbird to create the builds, because as far as I can tell their build infrastructure is just broken, so I'm going to stop wasting time on it.....
(Reporter)

Comment 15

6 years ago
(In reply to Boris Zbarsky (:bz) from comment #14)
> I strongly suggest finding someone who actually works on Thunderbird to
> create the builds, because as far as I can tell their build infrastructure
> is just broken, so I'm going to stop wasting time on it.....

Can you recommend someone?
Not offhand.  I don't really follow Thunderbird development....
(Reporter)

Comment 17

6 years ago
Ludovic, since you are MozillaMessaging QA lead, please advise.  This is pretty significant visual regression, which can be reliably reproduced in TB 7.0 (but also manifests in Fx), take a look at the video.  I need test builds with specific changeset(s) to identify the bug that fixes this.
(Reporter)

Comment 18

6 years ago
Can somebody help with this or recommend someone who can help?
Since Thunderbird shares Gecko's Core with Firefox, Nightly Builds found in http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/ should be sufficient, no?
(Reporter)

Comment 20

6 years ago
(In reply to XtC4UaLL [:xtc4uall] from comment #19)
> Since Thunderbird shares Gecko's Core with Firefox, Nightly Builds found in
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-
> central/ should be sufficient, no?

Sufficient for what?  I already found the fix window (comment 2), now I am looking to verify that the fix from specifically bug 657401 takes care of this bug, for that I need a tb 2011-08-12 central build with only bug 657401 patch applied.  A current beta + bug 657401 would probably work too.  Surely tb supports such try builds?  So who knows how to make one?
(In reply to al_9x from comment #20)
Yep, fail on my Side for not reading Comment 0 carefully enough.
(Reporter)

Comment 22

6 years ago
I built tb-7.0b2 myself with and without the Bug 657401 patch, and can confirm that it does take care of this bug (at least in TB)

@asa - please review the decision to not backport, in light of the symptoms described in this bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 657401
In particular, the backport discussion should happen in bug 657401.

Comment 25

6 years ago
Comments in bug 657401 about why we don't want to take this...
You need to log in before you can comment on or make changes to this bug.