"about:newaddon" in urlbar instantly closes tab/browser.

VERIFIED FIXED in mozilla10

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: patrickjdempsey, Assigned: felix)

Tracking

9 Branch
mozilla10
x86
All
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20111118])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.20) Gecko/20110803 Firefox/3.6.20
Build ID: 20110803131630

Steps to reproduce:

Type "about:newaddon" in urlbar attempting to show the Install Add-on tab dialog in an attempt to work on the theme style.


Actual results:

Tab instantly closes... if only one tab, browser instantly closes.  No crash report is generated.  If only one tab and browser closes, must delete places.sqlite and sessionstore files in profile to re-open browser.


Expected results:

Display a placeholder  "about:newaddon" page like blank about:sessionrestore page.

Updated

6 years ago
Blocks: 476430

Comment 1

6 years ago
Confirmed on Nightly9.0a1 and Aurora8.0a2.

http://hg.mozilla.org/mozilla-central/rev/d772dfb96ba1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110901 Firefox/9.0a1 ID:20110901030807
and
http://hg.mozilla.org/releases/mozilla-aurora/rev/03b0d42603f8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/8.0a2 ID:20110901042012
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

6 years ago
Confirmed on Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110901 Firefox/9.0a1
OS: Windows XP → All
(Assignee)

Updated

6 years ago
Assignee: nobody → ffung
(Assignee)

Comment 3

6 years ago
Created attachment 563646 [details] [diff] [review]
"about:newaddon" should not close tab/browser

Summary of Changes:
- If there is no id parameter, show about:blank instead of closing window.
Attachment #563646 - Flags: review?(bzbarsky)
Attachment #563646 - Flags: review?(bzbarsky) → review?(dtownsend)

Updated

6 years ago
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Attachment #563646 - Flags: review?(dtownsend) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/05a4fd114908
Flags: in-testsuite-
Target Milestone: --- → mozilla10
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/05a4fd114908
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 6

6 years ago
Maybe it's not important, but there's another window.close() a few lines down for if there is an id which isn't valid, so I guess typing "about:newaddon?blah" would still close the tab/window.

Comment 7

6 years ago
I have verified this on latest Nightly:
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111011 Firefox/10.0a1

and typing "about:newaddon" doesn't close the tab anymore instead it shows a blank tab even though I have new add-ons installed.
This is intended?
Thanks.
(Assignee)

Comment 8

6 years ago
Yes this is intended.
(Assignee)

Comment 9

6 years ago
On second thought. This should be improved some more. The expected behavior should be:

If you only have one tab and you direct it to about:newaddon, it should point you to about:blank.
If you have multiple tabs and you direct it to about:newaddon, it should close the tab.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Felix Fung (:felix) from comment #9)
> On second thought. This should be improved some more. The expected behavior
> should be:
> 
> If you only have one tab and you direct it to about:newaddon, it should
> point you to about:blank.
> If you have multiple tabs and you direct it to about:newaddon, it should
> close the tab.

I don't think this is really worth the effort, and I certainly don't want the code in there to be reliant on tabbrowser APIs
Also, this patch landed, followup patches go in new bugs.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 702048

Comment 13

6 years ago
Verified on GNU/Linux (comment 7, comment 8) by chaos, vladmaniac and me with at least these builds:
Aurora: Mozilla/5.0 (X11; Linux x86_64; rv:10.0a2) Gecko/20111117 Firefox/10.0a2
Nightly: Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111117 Firefox/11.0a1
Nightly: Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111117 Firefox/11.0a1
Status: RESOLVED → VERIFIED
Whiteboard: [testday-20111118]
What about a manual test? Do we need one here, because we can't cover it by automation? I would tend to say so.
Flags: in-litmus?
(In reply to Henrik Skupin (:whimboo) from comment #14)
> What about a manual test? Do we need one here, because we can't cover it by
> automation? I would tend to say so.

for FFTs IMO
There's no use spending time manually testing something that no average user will ever do.
Flags: in-litmus? → in-litmus-
You need to log in before you can comment on or make changes to this bug.