It takes a long time for some patches to get r's and sr's. Important patches bitrot, contributors get frustrated

RESOLVED WORKSFORME

Status

mozilla.org
Governance
RESOLVED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Jason Eager, Unassigned)

Tracking

Details

(Reporter)

Description

18 years ago
First, I'd like a data point. How many people who contribute patches e-mail
their patches to
reviewers@mozilla.org?

The main problem that I'm describing with this bug is that there are many *many*
bugs that have
fixes in hand where the patches have starved and/or bitrotted due to lack of
attention. The bug sits
there, already having the cure sitting right in front of us, but weeks and weeks
go by without
any response. And many of the contributors are too nieve to know that sometimes
you have to
send up a flare or two to get the review process back on track.

I can understand that the module owners are busy, but it would be nice to know
if these patches
just end up being missed (not seen), or are the reviewers that far backlogged?
It would be nice to
know if a patch has entered the queue to be reviewed, or if a person has started
the review process, but
know it may be a day or two before s/he finished to the point where the person
can give a r= or sr=.
(Reporter)

Comment 1

18 years ago
Changed summary to remove any possible offensiveness from it.
Summary: It takes forever to get r's and sr's. Important patches bitrot, contributors get frustrated → It takes a long time for some patches to get r's and sr's. Important patches bitrot, contributors get frustrated

Comment 2

18 years ago
Reassigning to brendan.  My guess is that some specific examples would be helpful.

mitchell
Assignee: mitchell → brendan
A generic bug like this is not helpful.  The drill is to mail staff@mozilla.org
(in case I am on vacation or whatever) when a module owner or bug owner appears
to be ignoring a patch.  Do that on a case by case basis, and you will get
better results.  Don't write about "many, many bugs" -- do enumerate those bugs
explicitly.

I'm marking this bug REMIND, but if you think case-by-case bugs against me that
refer to *other* bugs that have languishing patches will help, then please
consider an alternative that doesn't add more bug bureaucracy: mail the bug to
staff@mozilla.org, cc: me on it, and ask whether the patch shouldn't be checked
in.  I'll get the relevant owner to respond (if there is a relevant owner; if
not, I'll try to find one).

/be
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → REMIND

Comment 4

17 years ago
Fixing bug 70436, "[rfe] link from attached patch to colored diffs 
(cvsview2.cgi)", would make it easier for reviewers and other people to 
understand patches quickly.
REMIND is deprecated per bug 35839.  Reopening sans target milestone, adding dep.
Status: RESOLVED → REOPENED
Depends on: 70436
Resolution: REMIND → ---
Sorry, I'm not going to do anything with a unconstitutionally vague bug like
this.  If you reopen it, you take it.  That's not to say everything is perfect,
just that this bug doesn't help make any particular thing better.

/be
Assignee: brendan → choess
Status: REOPENED → NEW

Comment 7

16 years ago
I agree with Brendan.  I've tracked down too many complaints of "this patch
hasn't gotten super-review" only to find the problem is something else.  So I
don't belive this sort of bug is helpful.

If you have specific cases, please let us know.  With detail.  As in a copy of
the email to the review/super-reviewer with patch attached, and a date.  Then
staff can respond to a known, verified problem.

If there are a lot of specific cases with problems, then eventually we would
have a bug with links to particular problems. 

Also cc'ing Myk, because I want the patch tracker feature in Bugzilla as soon as
can be managed. 
--> Governance
Assignee: choess → nobody
Component: Miscellaneous → Governance
QA Contact: mitchell → governance

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.