Last Comment Bug 684472 - Reduce QIs in nsPrintingPromptService
: Reduce QIs in nsPrintingPromptService
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Embedding: APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: :Ms2ger
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-03 02:47 PDT by :Ms2ger
Modified: 2011-09-18 07:02 PDT (History)
1 user (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (8.78 KB, patch)
2011-09-03 02:47 PDT, :Ms2ger
benjamin: review+
Details | Diff | Splinter Review

Description :Ms2ger 2011-09-03 02:47:08 PDT
Created attachment 558053 [details] [diff] [review]
Patch v1

I think you own this...
Comment 1 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2011-09-09 13:30:44 PDT
Comment on attachment 558053 [details] [diff] [review]
Patch v1

>diff --git a/embedding/components/printingui/src/unixshared/nsPrintingPromptService.cpp b/embedding/components/printingui/src/unixshared/nsPrintingPromptService.cpp


>+    nsCOMPtr<nsIWebProgressListener> myWebProgressListener = this;
>+    myWebProgressListener.forget(webProgressListener);

This is weird. The normal way to do this is NS_ADDREF(*webProgressListener = this);

r=me with that change. I didn't review the OS/2 bits at all, since I just don't care.
Comment 2 :Ms2ger 2011-09-18 07:02:16 PDT
I'm no fan of NS_ADDREF, but sure.

http://hg.mozilla.org/mozilla-central/rev/8540ca31ca8f

Note You need to log in before you can comment on or make changes to this bug.