Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: r.yerin, Unassigned)

Tracking

6 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 558072 [details]
middle.png

User Agent: Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110816220020

Steps to reproduce:

Open a webpage with a background (file attached)


Actual results:

I see invalid colors in an attached file.


Expected results:

Please try to see an attached file in a gnome eye or google chrome and you will see another colors

Comment 1

7 years ago
Does the issue still occur if you start Firefox in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile?
https://support.mozilla.com/en-US/kb/Basic+Troubleshooting#w_8-make-a-new-profile


Are you able to attach a screenshot which shows the difference?
Please open about:config (enter as URL) and change gfx.color_management.mode to "0" (default is 2).
This will disable the color management for images with a color profile.
There is something wrong with your color management setup or graphic driver if that fixes the problem
(Reporter)

Comment 3

7 years ago
(In reply to Matthias Versen (Matti) from comment #2)
> Please open about:config (enter as URL) and change gfx.color_management.mode
> to "0" (default is 2).
> This will disable the color management for images with a color profile.
> There is something wrong with your color management setup or graphic driver
> if that fixes the problem

Thanks a lot, Matthias!
I've changed appropriate config property and pngs shown ok now.
Could you please give me a link where can I read more about this issue?
>Could you please give me a link where can I read more about this issue?
I'm not sure what kind of link you want.
An example for a driver bug is bug 660764
Read http://en.wikipedia.org/wiki/Color_management if you want to know what color management is.
BTW:You don't get the wrong colors in most other browsers because they don't have this feature.
(Reporter)

Comment 5

7 years ago
(In reply to Matthias Versen (Matti) from comment #4)
> >Could you please give me a link where can I read more about this issue?
> I'm not sure what kind of link you want.
> An example for a driver bug is bug 660764
> Read http://en.wikipedia.org/wiki/Color_management if you want to know what
> color management is.
> BTW:You don't get the wrong colors in most other browsers because they don't
> have this feature.

Now I see... I have read https://developer.mozilla.org/En/ICC_color_correction_in_Firefox
Thank you one more time, this is exactly feature, not a bug:) Now I'll be more attentive with a color profiles in my pngs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.