Task view rows get a border after restarting (aero theme not applied)

RESOLVED FIXED in 1.3

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: alistair.low, Assigned: Paenglab)

Tracking

Lightning 1.0b5

Details

Attachments

(4 attachments, 3 obsolete attachments)

(Reporter)

Description

7 years ago
Created attachment 558073 [details]
before.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1
Build ID: 20110830092941

Steps to reproduce:

1. Install Lightning from a clean Thunderbird profile.
2. Hide the Today pane and the task details pane.
3. Add some tasks.
4. Restart the application 3 or 4 times.


Actual results:

A single pixel dotted border appears between columns in the task list table. A larger dotted border appears between the rows.

A Thunderbird update temporarily fixes it but then after a few more restarts the problem re-appears.


Expected results:

The task view should stay as intended, without borders between the rows and columns.
(Reporter)

Comment 1

7 years ago
Created attachment 558074 [details]
Showing borders
(Reporter)

Comment 2

7 years ago
I managed to work around this by removing the following lines from \extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103}\chrome\calendar\skin\calendar\calendar-task-view.css:

#calendar-task-tree > .calendar-task-tree > treechildren::-moz-tree-row {
    border-bottom: 1px dotted #AAA;
}

#calendar-task-tree > .calendar-task-tree > treechildren::-moz-tree-cell {
    border-right: 1px dotted #AAA;
}
(Assignee)

Comment 3

7 years ago
The borders are only a symptom of not correctly loading the aero css files. You see this also on the thick borders or the sidebar header of the today-pane panel.

Philipp would it be okay, when I try a other attempt to activate the aero css files?
Status: UNCONFIRMED → NEW
Ever confirmed: true
So it is related or identical to Bug 668127?
(Assignee)

Comment 5

7 years ago
(In reply to Stefan Sitter from comment #4)
> So it is related or identical to Bug 668127?

Yes, identical
(Assignee)

Comment 6

7 years ago
Created attachment 562296 [details] [diff] [review]
Other approach to bind aero files

This is an other approach to bind the aero files. It is like the technique how FX and TB are adding the Aero theme but only for some files. The files are then added with @import to the css styles. The 0 byte files in XP folder are to avoid errors in XP mode.

I'm using this attempt since a longer time and had newer the problem of not loaded aero files as before also whit a lot of testing.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #562296 - Flags: review?(philipp)
Summary: Task view rows get a border after restarting → Task view rows get a border after restarting (aero theme not applied)
(Assignee)

Comment 7

7 years ago
A short description how this patch is working.

With defining

% skin win_OS classic/1.0 chrome/calendar/skin/calendar/XP/ os=WINNT osversion<6
% skin win_OS classic/1.0 chrome/calendar/skin/calendar/Aero/ os=WINNT osversion>=6

win_OS is used as a skin resource (I hope this is the right description). Depending of the used OS a directory is assigned to this resource.

Now on a CSS file with @import url(chrome://win_OS/skin/calendar.css) a file with special definitions can be imported. The XP file is zero bytes because no special definitions are needed, but the file exists to prevent a error message of a not existing file. This could be changed to shorten the main file and make it easier to the aero file to not override definitions.

That's all the magic. I'm using this in my themes (and also a lot of other themers) and since this change I haven't seen the not loading of the aero styles. With a default Lightning after some restarts the not loading happens and only deleting startupCache.4.little (naturally with TB not running) reverts to the aero styles.
(Assignee)

Comment 8

7 years ago
Created attachment 578828 [details] [diff] [review]
Other approach to bind aero files v2

Unbitrotted patch
Attachment #562296 - Attachment is obsolete: true
Attachment #562296 - Flags: review?(philipp)
Attachment #578828 - Flags: review?(philipp)
Comment on attachment 578828 [details] [diff] [review]
Other approach to bind aero files v2


>+% skin win_OS classic/1.0 chrome/calendar/skin/calendar/XP/ os=WINNT osversion<6
>+% skin win_OS classic/1.0 chrome/calendar/skin/calendar/Aero/ os=WINNT osversion>=6

I'd prefer to lowercase the platform names, maybe win-classic and win-aero?

Also, win_OS sounds very general and its well possible that someone else will have the same idea. This should rather be "calendar-windows", or "calendar-aero" (although that may be misleading).


Aside from the naming, r=philipp
If you need this on the (now merged) aurora or beta, approval for that and be sure to push asap.
Attachment #578828 - Flags: review?(philipp) → review+
(Assignee)

Comment 10

7 years ago
Created attachment 583832 [details] [diff] [review]
Patch for check-in

(In reply to Philipp Kewisch [:Fallen] from comment #9)
> Comment on attachment 578828 [details] [diff] [review]
> Other approach to bind aero files v2
> 
> 
> >+% skin win_OS classic/1.0 chrome/calendar/skin/calendar/XP/ os=WINNT osversion<6
> >+% skin win_OS classic/1.0 chrome/calendar/skin/calendar/Aero/ os=WINNT osversion>=6
> 
> I'd prefer to lowercase the platform names, maybe win-classic and win-aero?

Done

> Also, win_OS sounds very general and its well possible that someone else
> will have the same idea. This should rather be "calendar-windows", or
> "calendar-aero" (although that may be misleading).

Done using calendar-windows

> Aside from the naming, r=philipp
> If you need this on the (now merged) aurora or beta, approval for that and
> be sure to push asap.

I'm first pushing to comm-central and wait if everything works. Then I'll push to comm-aurora (because of the Tabs on Top followup patch for calendar).
Attachment #578828 - Attachment is obsolete: true
Attachment #583832 - Flags: review+
(Assignee)

Comment 11

7 years ago
Pushed to comm-central: <http://hg.mozilla.org/comm-central/rev/8f98ccdf3d9b>
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4

Comment 12

7 years ago
(In reply to Richard Marti [:paenglab] from comment #11)
> Pushed to comm-central: <http://hg.mozilla.org/comm-central/rev/8f98ccdf3d9b>

This removes lightning-aero.css but there is still a reference in
calendar/lightning/jar.mn

<http://hg.mozilla.org/comm-central/file/8f98ccdf3d9b/calendar/lightning/jar.mn#l59>

Comment 13

7 years ago
This causes:
http://tinderbox.mozilla.org/showlog.cgi?log=CalendarTrunk/1324580358.1324590934.22916.gz

RuntimeError: File "themes/winstripe/lightning-aero.css" not found in e:\buildbot\comm-central-win32\build\calendar\lightning, e:\buildbot\comm-central-win32\build\objdir-tb\calendar\lightning
make[4]: *** [libs] Error 1
make[3]: *** [libs_tier_app] Error 2
make[2]: *** [tier_app] Error 2
make[1]: Leaving directory `/e/buildbot/comm-central-win32/build/objdir-tb'
make[1]: *** [default] Error 2
make: *** [build] Error 2

Did you actually test your patch before pushing? You do have a try server after all.

Comment 14

7 years ago
Created attachment 584022 [details] [diff] [review]
Build Bustage Fix.

This patch builds locally. Hope this turns the tinderbox green.
Attachment #584022 - Flags: review?(philipp)
(Assignee)

Comment 15

7 years ago
Philip, thank you for the bustage fix. I'm at work and can't do anything.
(Assignee)

Comment 16

7 years ago
(In reply to Philip Chee from comment #14)
> Created attachment 584022 [details] [diff] [review]
> Build Bustage Fix.
> 
> This patch builds locally. Hope this turns the tinderbox green.

+% style chrome://lightning/content/messenger-overlay-sidebar.xul chrome://calendar/skin/win-aero/lightning.css os=WINNT osversion>=6

This line isn't needed.

Comment 17

7 years ago
Created attachment 584024 [details] [diff] [review]
Build Bustage Fix v2.0

> +% style chrome://lightning/content/messenger-overlay-sidebar.xul chrome://calendar/skin/win-aero/lightning.css os=WINNT osversion>=6

> This line isn't needed.
Fixed.
Attachment #584022 - Attachment is obsolete: true
Attachment #584022 - Flags: review?(philipp)
Attachment #584024 - Flags: review?(philipp)
Comment on attachment 584024 [details] [diff] [review]
Build Bustage Fix v2.0

r=philipp
Attachment #584024 - Flags: review?(philipp) → review+
Pushed to comm-central changeset a6e30fd92350
Target Milestone: 1.4 → 1.3

Updated

7 years ago
Duplicate of this bug: 668127
You need to log in before you can comment on or make changes to this bug.