"Save Image As..." context menuitem does not work on about:home

RESOLVED DUPLICATE of bug 649933

Status

()

Firefox
Menus
--
trivial
RESOLVED DUPLICATE of bug 649933
6 years ago
6 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/472716252ea3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110903 Firefox/9.0a1 ID:20110903030832

"Save Image As..." context menuitem does not work on about:home.

The menuitem should be disabled.
OR
Allow execute "Save Image As...".

Reproducible: Always

Steps to Reproduce:
1. Open Firefox with clean profile
2. Open about:home
3. Right click on Firefox Logo
4, Save Image As...

Actual Results:
  Nothing happens.
  An eoor in Error Console:

  Error: uncaught exception: Load of chrome://branding/content/about-logo.png from about:home denied.


Expected Results:
  The menuitem should be disabled.
  OR
  Allow execute "Save Image As...".
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 649933
You need to log in before you can comment on or make changes to this bug.