GUI becomes (periodically) unresponsive during background mail downloading (IMAP)

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Davor, Unassigned)

Tracking

({perf})

6 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caused by MSE])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)

Steps to reproduce:

Simply downloading mails.


Actual results:

The GUI is very unresponsive for periods of 1~2seconds. It's as if the GUI and mail downloading happens in the same thread. Quite annoying.



Expected results:

The GUI should be responsive.
(Reporter)

Comment 1

7 years ago
Apparently this is because of MSE running in the background and checking the mails while they are downloaded.

Still, I don't understand why the GUI blocks.

Comment 2

7 years ago
be(In reply to Davor from comment #1)
> Apparently this is because of MSE running in the background and checking the mails while they are downloaded.

because activity in MSE blocks the entire thunderbird
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Keywords: perf
Resolution: --- → INVALID

Updated

7 years ago
Whiteboard: [caused by MSE]
(Reporter)

Comment 3

7 years ago
Ok, I agree that MSE is the cause, but I do not agree that it is also the problem. MSE, like any other antivirus software, is just doing it’s job. 

I still think that the problem is with Thunderbird and the way the GUI interacts with the downloading and file-accessing threads. These interactions could be optimized so that the GUI does not freeze if access to a file is delayed.
You need to log in before you can comment on or make changes to this bug.