Increase in GIF animation CPU usage

RESOLVED DUPLICATE of bug 666446

Status

()

defect
RESOLVED DUPLICATE of bug 666446
8 years ago
8 years ago

People

(Reporter: bws42, Unassigned)

Tracking

({regression})

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Between september 3rd/4th there seems to be an increase in the CPU usage for animating GIFs. I'm afraid I'm not sure where to find the right set of hourly builds for mozilla-inbound to provide a better regression range:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=472716252ea3&tochange=a351ae35f2c4

I was using the reply functionality of a phpBB forum to test this, specifically:
http://forums.mozillazine.org/posting.php?mode=reply&f=38&t=2297159

Before the change I was seeing 55-60% CPU usage by Firefox (still seems high)
After the change I was seeing 85-90% CPU usage

Hitting ESC to stop the animations drops CPU usage to near 0%.
Will, if you're looking for 64-bit Linux hourlies from inbound, you can find those at http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-linux64/

If you want some other build configuration, let me know which one?

Nothing in the comment 0 range jumps out at me.  :(

Comment 2

8 years ago
Also if another window covers the animated gifs, CPU usage drops to almost 0%
(Reporter)

Comment 3

8 years ago
(In reply to Boris Zbarsky (:bz) from comment #1)
> Will, if you're looking for 64-bit Linux hourlies from inbound, you can find
> those at
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-
> inbound-linux64/

I'd found those earlier but was having trouble finding the right ones to bisect the range I had. I tried a little harder today and now I can't reproduce...

Ahh, however, I see where my testing was biased. When I saw the higher CPU usage I was using my normal session which has a larger window. Doing the testing I used a new clean profile and just copied over the URL. Making the window larger causes an increase in CPU usage and shrinking it causes it to decrease.

Should those 12 animating GIFs really be causing that much usage? I realize this is probably tracked in a different bug and this should be closed as a dupe/wfm.
> Should those 12 animating GIFs really be causing that much usage? 

It sort of depends on how often we end up repainting, how much needs to be repainted, and how often they animate...

Bug 666446 might help here too.
(Reporter)

Comment 5

8 years ago
Fair enough, I'll mark this as a dupe of bug 666446. Thanks Boris.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 666446
You need to log in before you can comment on or make changes to this bug.