Assertion failure: false, at jsscript.cpp:302

RESOLVED DUPLICATE of bug 684623

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 684623
6 years ago
6 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86
Linux
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 558254 [details]
Test case for shell (see README file inside).

The following test asserts on mozilla-central revision a351ae35f2c4 (with shell build fix from mozilla-inbound rev fff3dc9478ce) 32 bit debug build. For exact running instructions, see README inside the tarball. 

Note that the original assert (before minimization) was different, it was:

Assertion failure: allocated(), at ../../jsgc.h:740

This test is quite fragile, let me know if you can't reproduce. I can provide shell access in that case.
Sadly, this was not the bug I was looking for. Thanks, though.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684623
You need to log in before you can comment on or make changes to this bug.