Closed Bug 684704 Opened 11 years ago Closed 11 years ago

move getfirebug.com to new generic cluster in phx1

Categories

(mozilla.org Graveyard :: Server Operations, task)

x86
macOS
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cshields, Assigned: bhourigan)

References

Details

getfirebug should be high on our list of sites to move to phx1, as they are currently having issues in sjc1.
These issues include bug 687288, which is a blocker for the Firebug team.
Assignee: jthomas → bhourigan
Sebastian,

I have seen all of the bugs related to getfirebug.com, this bug is a blocker to the rest of the fixes. I will be working with you after the migration to get everything fixed.

Please test the site at http://getfirebug.allizom.org. If the site functions the same as http://getfirebug.com we can complete this migration and begin working on your Perch issues.
Both getfirebug.com and blog.getfirebug.com are now live off of phx1 cluster. I worked with Honda in #firebug to validate site functionality both before and after the move.

In order to update the site from svn in the future please file a bug for us to pull the latest code and deploy to our cluster.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
> In order to update the site from svn in the future please file a bug for us to 
> pull the latest code and deploy to our cluster.
If there's no automatic mechanism anymore to put page changes live, this is a big regression. Having to ask for a deploy everytime we change something is very time intensive.
The idea behind bug 677682 was to improve the speed changes to the code are going live.
How often are you making updates to the site?
Depending on the changes we need there can be weeks between updates, but sometimes (like in the current case of the Swarms page) there are several updates per day.
(In reply to Brian Hourigan [:digi] from comment #5)
> How often are you making updates to the site?
Note that changes we are making in SVN (in tests dir) used to be online on getfirebug.com in 15-20 minutes. This is important since all our test files needs to be online for others to run Firebug test suite. Also automated test-bot (running on Mozilla servers) is using some of these online files.

This SVN directory:
http://code.google.com/p/fbug/source/browse/#svn%2Ftests

should be regularly synced with:
http://getfirebug.com/tests/

Honza
Blocks: 699388
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.