pseudo-class ":after" and ":before" do not work

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: Erlon Charles, Unassigned)

Tracking

5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110622232052

Steps to reproduce:

estou utilizando em meu CSS as pseudo-classes ":after"  e ":before" 


Actual results:

none of these properties had an effect


Expected results:

the style settings should work the same way that work in versions prior to Firefox 5.0
(Reporter)

Comment 1

7 years ago
These errors were seen in clients firefox for linux (ubuntu) and customers windows7 versions 5.0 and 6.0.1

Steps to reproduce:

I am using in my CSS pseudo-classes ": after" and "before"

Comment 2

7 years ago
Please provide a public URL or reduced test case that exhibits this issue.
Keywords: testcase-wanted
(Reporter)

Comment 3

7 years ago
The url where these errors were found was http://sgep.vti.com.br/.
This is a system that is still in development, and for now I have no permission to display other screens with the same errors, but this page shows the errors menscionados.
Labels should appear in "*" (asterisk) in red to show that they are required fields, but these do not appear as asterisks are inserted using the pseudo-classes ": after"

ps: sorry for my English (google translator working)

Comment 4

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

Works fine here on winXP ("Usuário" followed by red "*")

Comment 5

7 years ago
WFM - Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110907 Firefox/9.0a1 ID:20110907030853

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
(Reporter)

Comment 6

7 years ago
Sorry for the inconvenience
observing the code now realized that the trainee has replaced all ":" why " : " (colon with space on both sides)
since the problem has been solved thank you note for attending
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.