Cursor jumps to the end of the line while typing in Google search field

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: Gili, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1
Build ID: 20110830092941

Steps to reproduce:

Edit text in the Google search field


Actual results:

Cursor unexpectedly jumped to the end of the line


Expected results:

Cursor should have remained in its current position
(Reporter)

Comment 1

7 years ago
Please see a related discussion here: http://forums.mozillazine.org/viewtopic.php?f=9&t=2291081&p=11180963

Here is a simple way to reproduce it.

1. Go to http://www.google.com/search?q=a+long+line+of+text&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a
2. Start entering text at the beginning of the top search field
3. Two seconds later, the cursor will jump to the end of the field while you're typing.

It's not clear whether this is a browser or Google bug. I first noticed this bug after upgrading from FireFox 6.0.0 to 6.0.1.

Comment 2

7 years ago
WFM - Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110905 Firefox/9.0a1 ID:20110905030839

The 6.0.1 update only removed a certificate so it would not be causing the issue.

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
(Reporter)

Comment 3

7 years ago
I forgot to mention, this problem only occurs if Google Instant is disabled.

1. Click on the gear icon in the top right
2. Search Settings
3. Do not use Google Instant
4. Save
5. Try the aforementioned repro steps

Yes, this problem is reproducible in Safe Mode. Yes, this problem is reproducible with an new profile.
Confirmed against:
Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110906 Firefox/9.0a1 ID:20110906030844
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.19) Gecko/2010031422 Firefox/3.0.19 ID:2010031422

With Firefox 2 Google Instant is not available.

This "smells" like a Site/TE Issue.
Status: UNCONFIRMED → NEW
Component: Account Manager → General
Ever confirmed: true
QA Contact: account.manager → general
Version: 6 Branch → Trunk

Comment 5

6 years ago
Gili -> Does this issue still occur with Firefox 8 and the latest version of Google's page?
(Reporter)

Comment 6

6 years ago
Tim,

No, because Google's search field no longer grabs focus.

Comment 7

6 years ago
Thanks for reporting back
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.