Last Comment Bug 684796 - Assertion failure: freeLists[kind].isEmpty()
: Assertion failure: freeLists[kind].isEmpty()
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla9
Assigned To: general
:
:
Mentors:
: 684940 (view as bug list)
Depends on:
Blocks: 674251
  Show dependency treegraph
 
Reported: 2011-09-05 22:10 PDT by Nicholas Nethercote [:njn]
Modified: 2011-09-07 08:00 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (2.05 KB, patch)
2011-09-06 06:30 PDT, Igor Bukanov
bhackett1024: review+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2011-09-05 22:10:30 PDT
js> mjitdatastats()
Assertion failure: freeLists[kind].isEmpty(), at /home/njn/moz/mi6/js/src/jsgc.h:1081
Aborted (core dumped)


I'm guessing this is related to bug 674251.
Comment 1 Nicholas Nethercote [:njn] 2011-09-05 22:12:06 PDT
I should say that removing mjitstats() from the shell would be an acceptable fix for this, IMHO, because I doubt anyone uses it.

But it would be good to know what the real problem is and if it could have other bad effects.
Comment 2 Igor Bukanov 2011-09-06 06:30:16 PDT
Created attachment 558460 [details] [diff] [review]
v1

In the bug 674251 I have used too strict assert in the gc::CellIter. The ieterator should allow for non-empty free lists synchronized with the arenas during the GC to support pseudo-GC sessions like one setup for cell enumeration.

This patch fixes that and also fixes another regression from bug 674251 where I wrongfully used gc::FINALIZE_TYPE_OBJECT, not gc::FINALIZE_SCRIPT, in the scripts enumerator.
Comment 5 Andrew McCreight [:mccr8] 2011-09-07 08:00:47 PDT
*** Bug 684940 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.