Last Comment Bug 684821 - Remove nsIDOMNSHTMLElement
: Remove nsIDOMNSHTMLElement
Status: RESOLVED FIXED
: addon-compat, dev-doc-needed
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on:
Blocks: deCOM
  Show dependency treegraph
 
Reported: 2011-09-06 04:21 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-10-30 05:25 PDT (History)
4 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (122.76 KB, patch)
2011-09-06 06:28 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review
Patch v2 (82.19 KB, patch)
2011-09-16 11:43 PDT, :Ms2ger (⌚ UTC+1/+2)
peterv: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-09-06 04:21:13 PDT

    
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2011-09-06 06:28:59 PDT
Created attachment 558459 [details] [diff] [review]
Patch v1
Comment 2 David Zbarsky (:dzbarsky) 2011-09-08 08:02:24 PDT
HTML5 microdata has nsIVariant attributes, which (last I checked) can't be quickstubbed, so I put them on nsIDOMNSHTMLElement.  How do you propose doing this once nsIDOMNSHTMLElement is gone?
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-09-16 11:43:38 PDT
Created attachment 560596 [details] [diff] [review]
Patch v2

David, not sure what the problem is. Not all nsIDOMHTMLElement members are quickstubbed after this patch.
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2011-10-01 09:06:08 PDT
Peter, ping?
Comment 5 Peter Van der Beken [:peterv] 2011-10-17 11:59:23 PDT
Comment on attachment 560596 [details] [diff] [review]
Patch v2

Review of attachment 560596 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/xpconnect/src/dom_quickstubs.qsconf
@@ +242,5 @@
> +    'nsIDOMHTMLElement.offsetParent',
> +    'nsIDOMHTMLElement.offsetTop',
> +    'nsIDOMHTMLElement.offsetLeft',
> +    'nsIDOMHTMLElement.offsetWidth',
> +    'nsIDOMHTMLElement.offsetHeight',

I'd just keep nsIDOMHTMLElement.*.

Note You need to log in before you can comment on or make changes to this bug.