Last Comment Bug 684862 - Pasted heading in Orion doesn't have a line number, and will disappear when navigating to another line
: Pasted heading in Orion doesn't have a line number, and will disappear when n...
Status: RESOLVED FIXED
[sourceeditor][orion]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: Firefox 10
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 685925 687850 687860 689559 (view as bug list)
Depends on: 692807
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-06 08:18 PDT by :Ehsan Akhgari (busy, don't ask for review please)
Modified: 2011-11-07 07:27 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description :Ehsan Akhgari (busy, don't ask for review please) 2011-09-06 08:18:46 PDT
STR:

1. Go to http://blog.mozilla.com/devtools/2011/09/06/do-you-write-right-to-left-help-us-test-the-code-editor/.
2. Select "How to reset your editor", and Copy.
3. Open Scratchpad, and hit Cmd+V.  The pasted heading has a heading style and is not on a line of its own.
4. Click on the 9th line.  The pasted heading disappears.
Comment 1 Mihai Sucan [:msucan] 2011-10-10 13:10:06 PDT
This is now fixed upstream in the latest Orion code.
Comment 2 Mihai Sucan [:msucan] 2011-10-10 13:33:36 PDT
*** Bug 687850 has been marked as a duplicate of this bug. ***
Comment 3 Mihai Sucan [:msucan] 2011-10-10 13:34:12 PDT
*** Bug 685925 has been marked as a duplicate of this bug. ***
Comment 4 Mihai Sucan [:msucan] 2011-10-10 13:40:51 PDT
*** Bug 689559 has been marked as a duplicate of this bug. ***
Comment 5 Mihai Sucan [:msucan] 2011-10-13 13:10:56 PDT
This is now fixed. Bug 692807 landed.
Comment 6 Bruce A. Wittmeier 2011-10-14 11:53:07 PDT
This is not fixed as the build Oct 14, 2011.  Built from http://hg.mozilla.org/mozilla-central/rev/9545b88eed82

Scratchpad still does not work.
Comment 7 Bruce A. Wittmeier 2011-10-14 11:54:39 PDT
Possibly related to this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=684445
Comment 8 Bruce A. Wittmeier 2011-10-15 07:04:34 PDT
This is not fixed as the build Oct 15, 2011.
Built from http://hg.mozilla.org/mozilla-central/rev/6d5fd5a30c71
Scratchpad still does not work.

This needs to be reopened or a new bug filed.  Might still be related to this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=684445
Comment 9 Mihai Sucan [:msucan] 2011-10-15 08:14:30 PDT
(In reply to Bruce A. Wittmeier from comment #8)
> This is not fixed as the build Oct 15, 2011.
> Built from http://hg.mozilla.org/mozilla-central/rev/6d5fd5a30c71
> Scratchpad still does not work.
> 
> This needs to be reopened or a new bug filed.  Might still be related to
> this bug:
> https://bugzilla.mozilla.org/show_bug.cgi?id=684445

Thank you for your report. This bug is not related to bug 684445 - that one simply asks for a new feature in one of our developer tools component (the Source Editor).

If you believe this bug is not yet fixed, please open a new bug. Provide your steps to reproduce, in the new bug, your system information (OS and version), Firefox version and build identifier, and any information you may deem relevant. Thank you!
Comment 10 Mihai Sucan [:msucan] 2011-10-19 11:45:04 PDT
*** Bug 687860 has been marked as a duplicate of this bug. ***
Comment 11 Alex Lakatos[:AlexLakatos] 2011-11-07 07:27:59 PST
VERIFIED on Build identifier: Mozilla/5.0 (X11; Linux i686; rv:10.0a1) Gecko/20111107 Firefox/10.0a1

Note You need to log in before you can comment on or make changes to this bug.