Moz Mail/News dies when selecting Newsgroup message it can't find

RESOLVED WORKSFORME

Status

MailNews Core
Backend
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: cmorley, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Bare with me, this is long.

Moz build 2001012720

Keys:
"group one" any newsgroup name.
"group two" any other newsgroup name.
"website one" any website URL
"website two" any other wesite URL

1. In newsgroups, clicked on message (in "group one").
2. if message happens to be unavailable (seems to be mozilla-brain-****) you
can't stop Moz from looking (by hitting the Stop button).
3. select "mark all read". Moz still looks for message, but marks the rest read.
4. select another group ("group two"). Note: pointer is now hourglass over group
names.
5. eventually Moz stops trying to get message, but still displays "group one" in
right pane, even though "group two" is clearly selected in the left pane.
6. hourglass continues to show when passing mouse over newsgroup names in left pane.
7. you can still select these newsgroups (with hourglass) but "group one's"
message list still displays in right pane.
8. Switch to browser, which was open on "website one".
9. Type in url bar "website two". Hit enter.
10. progress bar at bottom says "sending request to "website one"". (not the one
I just typed ("website two").
11. Moz is done here.  Not froze, just not getting web content and not telling
you anything.
12. Started up IE and found my connection to be working just fine.

13. restarted Moz and all was working.

Whew!

cm

Updated

17 years ago
QA Contact: esther → stephend
Summary: Moz Mail/News dies when sellecting Newsgroup message it can't find → Moz Mail/News dies when selecting Newsgroup message it can't find
Okay, I'm going to try to reproduce, but Seth, I think this is just one of our
many focus problems.
Assignee: mscott → sspitzer
Okay, don't we have *tons* of focus bugs?  Should I re-assign this to you Chris?

Comment 3

17 years ago
You could assign it to me, but it will be low on my priority list. If you want
it fixed in this dev cycle, don't give it to me.
Basically, the problem with this is that we're horrible with focus when a
message ID isn't being found.  Confirming, anyone know of a DUP though?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have tried to reproduce this bug but sofar I have failed. Mozilla seema to be
handling missing messageID's just fine, giving me an error message in the
message pane.

Perhaps this bug has been fixed by now, can we close it ?
Any progress on, if this is still an issue ??

I will most likely close this bug in around two month if noone can can confirm
it is still an issue
Product: MailNews → Core

Comment 7

13 years ago
WFM (although not able to replicate exactly all the reporters steps).
Please reopen with reduced test case and full details of PC environment if still
a problem.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.