RSS feed has all entries as 12/31/1969

RESOLVED WORKSFORME

Status

MailNews Core
Feed Reader
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Rick Gillaspy, Unassigned)

Tracking

({testcase})

x86
Windows XP
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.220 Safari/535.1

Steps to reproduce:

Attempted to subscribe to http://feeds.feedburner.com/NCRegisterDailyBlog


Actual results:

All entries are dated 12/31/1969 7:00 pm


Expected results:

Should have been correct date.

The RSS xml appears to have a different format for dc:date than thunderbird is expecting.

Other RSS readers seem to work ok with it.

Sample xml:

    <item>
      <title>Verifying the 4 Gospels, Why Catholics Have Large Families, Catholic Romance Novel Boom, and more!</title>
      <link>http://feedproxy.google.com/~r/NCRegisterDailyBlog/~3/vbHIIcq1NsQ/verifying-the-4-gospels-why-catholics-have-large-families-catholic-romance-</link>
      <guid isPermaLink="false">http://www.ncregister.com/daily-news/verifying-the-4-gospels-why-catholics-have-large-families-catholic-romance-#When:2011-09-6</guid>
            <description>By TITO EDWARDS | Are the Four Gospels Historically Verifiable? - Taylor Marshall, Canterbury Tales Does Property Have a Purpose? - Thomas Storck, Distributist Review Mother Teresa: How to Love God - Lisa Graas, The American Catholic Reflections on Conversion - Andrew Votipka, VirtuousPla.net Why Do Catholics Have Big Families? - Phil Lawler, CatholicCulture.org/On the News How Do I Tell People &amp;#8230;&lt;img src="http://feeds.feedburner.com/~r/NCRegisterDailyBlog/~4/vbHIIcq1NsQ" height="1" width="1"/&gt;</description>
            <dc:subject />
      <dc:date>2011-09-6</dc:date>
    <feedburner:origLink>http://www.ncregister.com/daily-news/verifying-the-4-gospels-why-catholics-have-large-families-catholic-romance-#When:2011-09-6</feedburner:origLink></item>

Comment 1

6 years ago
(In reply to Rick Gillaspy from comment #0)
Works for me. Dates are displayed correctly
User Agent: Mozilla/5.0 (X11; Linux i686; rv:7.0) Gecko/20110922 Thunderbird/7.0
Build ID: 20110922212718
(Reporter)

Comment 2

6 years ago
Try now.  I think it has to do with when the days are 1 digit, so It only appears during the 1st through the 9th of the month.

(In reply to Hashem Masoud from comment #1)
> (In reply to Rick Gillaspy from comment #0)
> Works for me. Dates are displayed correctly
> User Agent: Mozilla/5.0 (X11; Linux i686; rv:7.0) Gecko/20110922
> Thunderbird/7.0
> Build ID: 20110922212718
Can you save the feed when this happens and attach the file to the bug ?
Component: General → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: general → feed.reader
(Reporter)

Comment 4

6 years ago
Created attachment 564160 [details]
feed contents with unexpected date format
Keywords: testcase

Comment 5

5 years ago
it looks like this publisher did the right thing and is now using the correct date format.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.