installing a plugin should not require restart

RESOLVED DUPLICATE of bug 256509

Status

()

RESOLVED DUPLICATE of bug 256509
7 years ago
7 years ago

People

(Reporter: hanriseldon, Unassigned)

Tracking

6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I installed a plugin. 


Actual results:

The browser promoted me for a restart. 


Expected results:

There should not be the need to restart the browser when installing a plugin. The plugin should be dynamically loaded. This is likely to require non-trivial changes, but it's one of the major drawbacks of Firefox.

Comment 1

7 years ago
This already exists since Firefox 4 for extensions that have chosen to support it. 
https://addons.mozilla.org/en-US/firefox/tag/restartless
https://developer.mozilla.org/en/Extensions/Bootstrapped_extensions

The support for this in the general case has recently been declared WONTFIX in bug 256509.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 256509
You need to log in before you can comment on or make changes to this bug.