Last Comment Bug 685174 - Firefox 6 background image repeat issue(signed 16-bit integer limit?)
: Firefox 6 background image repeat issue(signed 16-bit integer limit?)
Status: RESOLVED DUPLICATE of bug 671302
dupme
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://hardincountychamber.org/Chambe...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-07 08:37 PDT by Chase Hubbard
Modified: 2012-11-30 03:21 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Chase Hubbard 2011-09-07 08:37:39 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1
Build ID: 20110830092941

Steps to reproduce:

As posted : http://stackoverflow.com/questions/7323082/firefox-6-background-image-repeat-issue

I realize that the title is a long one, but allow me to explain. If you look at:

http://hardincountychamber.org/Chamber-Commerce-Directory.asp

The background disappears after you scroll for a while. As quoted from a comment in the thread above, "if you check, that happens when you scroll the page down by slightly more than 32000 pixels (yep, signed 16-bit integer limit)."

The same user says that things are even worse in FF9, because the background never comes back after that limit.


Actual results:

in Firefox 6 (Windows 7 64bit), the white background will repeat until around halfway through the letter 'D' of the full directory, and then disappear after one small move of the mouse wheel, and then resume displaying just a little further down the page. The background just snaps back to displaying. Personally I am baffled as to what is causing it, and in the back-end admin section of this page, the same thing occurs with another repeated background image.

So to duplicate the bug, at the time of this postings, search for the term, "Starbuck" on the page, and then scroll until that listing is at top of your browser, then scroll down slowly, and the white background should just disappear.


Expected results:

The background image should have continued to repeat until the end of the element.
Comment 1 Wladimir Palant 2011-09-07 09:03:30 PDT
Confirming and CC'ing roc given that all this sounds awfully similar to bug 215055. I reproduced the issue both in Firefox 6 and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110904 Firefox/9.0a1. In the nightly the effect is somewhat different, the background image entirely disappears after ~32000 pixels.
Comment 2 j.j. 2011-09-07 13:20:02 PDT
See also bug 672726 and bug 683681
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-09-07 19:32:41 PDT
Sounds very much like a cairo graphics issue. Is Direct2D enabled? (See about:support.)
Comment 4 Jeff Muizelaar [:jrmuizel] 2011-09-07 19:44:54 PDT
This sounds like bug 671302
Comment 5 Wladimir Palant 2011-09-08 00:30:24 PDT
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #3)
> Sounds very much like a cairo graphics issue. Is Direct2D enabled? (See
> about:support.)

I don't have Direct2D enabled (Intel graphics with a driver that is apparently too old). DirectWrite and GPU acceleration are also disabled.

(In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> This sounds like bug 671302

Yes, with the difference that this is not a recent regression - the issue is reproducible in Firefox 6 as well. However, it is different in Firefox 6, what I see in Firefox 9 matches bug 671302 on the other hand.
Comment 6 Wladimir Palant 2011-09-08 05:33:31 PDT
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #3)
> Sounds very much like a cairo graphics issue. Is Direct2D enabled? (See
> about:support.)

I've updated my graphics driver and the issue disappeared. I now have Intel 4 Series Express Chipset Family driver version 8.15.10.2413 installed and Direct2D is enabled. Previously I had version 8.15.10.1892 (which is already newer than what the computer manufacturer provides, probably installed via Windows Update - now I had to get the driver directly from Intel and use the documented work-around because it wouldn't install).
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-09-08 05:48:52 PDT
Sounds very much like bug 671302 then.
Comment 8 :aceman 2011-10-03 04:57:34 PDT
It seems they have clipped the page in the testcase to show only 500 entries so it does not run to the letter 'D'. So I can't see the bug there, the page is probably too short now.
Comment 9 Chase Hubbard 2011-10-03 05:37:32 PDT
Yes, we had to have the results display in pages, because the client for the site was complaining about it. Now that I have upgraded to FF 7, the background never re-shows itself. I have created a test page from the backup, so you can continue to see the error, and it is available here:

http://hardincountychamber.org/Chamber-Commerce-Directory-test.asp
Comment 10 j.j. 2011-11-04 09:48:36 PDT

*** This bug has been marked as a duplicate of bug 671302 ***

Note You need to log in before you can comment on or make changes to this bug.