iMac fails to connect to ATT 2Wire 721 modem in wireless mode & no other computer attempting access

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: James Mears, Unassigned)

Tracking

6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0.1) Gecko/20100101 Firefox/6.0.1
Build ID: 20110830092941

Steps to reproduce:

At power up, iMac fails to connect to AT&T 2-wire 721 modem. A re-start does not always result in connection with the modem. A re-start of the modem does not always result in a successful connection attempt. Computer and modem are less than 4ft apart. This is a consistent problem. Repeatable but intermittent. Would estimate >50% of power-ups result in failure to connect.


Actual results:

No connection via wireless link.


Expected results:

Would have expected to connect to 2-Wire 721 modem initially or after computer re-start or modem re-start.
and why do you think that this a Firefox problem and not something with the OS, the modem or the network ?
Does it work with other browsers like Safari ?
(Reporter)

Comment 2

6 years ago
(In reply to Matthias Versen (Matti) from comment #1)
> and why do you think that this a Firefox problem and not something with the
> OS, the modem or the network ?
> Does it work with other browsers like Safari ?

I use Firefox mostly. Will experiment with Safari & the OS to see what I can determine. Cannot determine if the network is at fault as I do not have any computer or communication system network analysis equipment or capabilities (wish I did!). AT&T will not provide DSL system fault analysis to residential users. iMac OS is latest & updated. Cannot determine at this time if OS could be at fault. Will investigate. (Guess I am out of retirement, 40+ years in electronics applications engineering including computer networks).
The OS provides usually enough tools to identify networking problems (ping, traceroute...) but they are not easy to use as user because you need some networking knowledge.
(Reporter)

Comment 4

6 years ago
Matti: Thanks for your suggestions and comments.

I have done several experiments attempting to isolate this problem. I have repeated observations supporting my theory of what is happening. I have also worked with AT&T to check for and correct any modem problems or problems with my phone/DSL system. I left no part of my computer/communication/phone system out of the investigation. No problems were found with the modem itself. The phone/comms system also seems to be working correctly.

What I know takes this issue on a detour which seems to rule out Firefox or the iMac OS as the culprit. 1) My wife uses a MS-Vista-based system for her embroidery software. That system uses a wired connection to the modem. When she shuts-down or hibernates that system, the modem ignores a subsequent log-on attempt from the iMac almost 100% of the time. The iMac uses its "Airport" wireless system to connect to the modem.  Re-booting the iMac usually establishes communication with the modem and it boots-up successfully. Also, resetting the modem clears the problem and allows the iMac to boot-up OK. This, by itself, would appear to eliminate both the Mac-OS and Firefox as the source of the problem.

I am still working on the additional idea that when the Vista machine is shut-down or hibernated while the iMac is communicating with the modem, that this causes the iMac to lose contact with the modem. Generally, re-starting Firefox and re-addressing the web-site previously being communicated with re-establishes communication. I need to collect additional incidents of this before drawing a conclusion.

I am now virtually 100% sure the problem resides outside of the iMac system. I believe that the problem is caused by the manner in which MS-Vista handles the modem.

May I recommend that my bug report be closed.
Thanks for the feedback !

The modem should notice that there is no connection to the vista box and should timeout....
I will close this bug as invalid because this is something on the networking side and that is managed by the OS and the hardware and not firefox.
Good luck with resolving your issue !
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.