[zh-TW][mobile][plugin] Affiliates program: mobile and plugins banners localization

VERIFIED FIXED in 1.0

Status

VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: Milos, Unassigned)

Tracking

unspecified

Details

(Whiteboard: [l10n][qa-])

Attachments

(3 attachments)

1002.70 KB, application/octet-stream
Details
2.32 MB, application/octet-stream
Details
265.42 KB, image/png
Details
(Reporter)

Description

7 years ago
Hello,

We're gonna use this bug to track progress of and work on mobile and plugins banner translation. I have copied over your translation from etherpad into this bug.

Now, it would be really awesome if you could create the banners based on PSD files that you can find attached in bug 674077

In case you are not able to do that, please comment in this bug, and we're gonna try to find someone who can help you with that.

Once the designs are ready, please attach them here, and we'll take care of the rest!

Thanks in advance.

P.S. Here's your translation from etherpad:
======
下載 Android 版本的 Firefox

這是您隨身帶著走的網路。下載 Android 版本的 Firefox

把網路帶在身邊。下載 Android 版本的 Firefox
======
(Reporter)

Comment 1

7 years ago
Sorry for mistake. Files attached in bug I mentioned in descriptions are only PNG files. I have uploaded PSD files to:

http://people.mozilla.org/~mdinic/FirefoxForMobilePSD.zip

Sorry for inconvenience.
Milos, We have Meta as standardized font for Firefox's Logo in Latin alphabets, but do we have any for CJK, or for Chinese words at least?

Comment 3

7 years ago
In the art works before at Mozilla Taiwan, I usually use these commercial fonts below in coordination to FF Meta,
華康儷黑 (DFLiHeiStd), 華康黑體 (DFHeiStd) from DynaComware Corp.,
If we want to keep it open, we can use 文泉驛微米黑 (WenQuanYiMicroHei), the derivative of Droid Sans, and 文泉驛正黑 (WenQuanYiZenHei) from WenQuanYi Board of Trustees.

I don't think the font would be problem, since it only affiliates images, we're not provide the original fonts files,
and I'm working on the images now.

Updated

7 years ago
Target Milestone: --- → 1.1

Comment 4

7 years ago
Created attachment 559688 [details]
L10n PNGs

L10ned PNGs attracted

Comment 5

7 years ago
Created attachment 559693 [details]
PSD for L10n PNG Files.

Updated

7 years ago
Target Milestone: 1.1 → 1.0
Thank for these Irvin!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Created attachment 568261 [details]
screenshot

Does the word "Desktop" in the menu need to be localized? As well?

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Matt Brandt [:mbrandt] from comment #7)
> Created attachment 568261 [details]
> screenshot
> 
> Does the word "Desktop" in the menu need to be localized? As well?

Well yes I think so, but the string "Desktop" is already localized on Verbatim.

The part of mentioning header in messages.po file is as below, it seems that the localized string of desktop was not used in the page template? 

#: templates/global/footer.html:40
msgid "Desktop"
msgstr "桌面"

#: templates/global/footer.html:53 templates/global/header.html:24
msgid "Mobile"
msgstr "行動"
Thank you Peter, that's fantastic.

Comment 10

7 years ago
I'm really angry for the final site.

1. The desktop Firefox affiliates image in currently site had not been available in this bug. I can't accept that I'd been contribution the mobile image, but don't have the chance to review the image for desktop firefox.

2. In Comment 5 I'd localized all the request image, but final outcome had been modify and become a REALLY MISTAKE. All the zh-tw mobile affailiates images shows "Download Firefox version's Android". WTF is That?

Comment 11

7 years ago
The grammar for chinese and grammer for english is really different, same as the other languages, that we can't just replace all the word in english materials to chinese and consider think we'd done the localization job, otherwist it will become a whole Joke in the final result, that's why we'd so much ppls contribute to the l10n project on Mozilla Community, and that's what I see at this project.

I always think Mozilla is a project growths with global respective.
Peter, 

The content for the buttons, we took the translation from this etherpad not from verbatim: https://etherpad.mozilla.org/ff-mobilebuttons-l10n

Hi Irvin, 
Thank you for your note. I'm sorry that you are angry about the final site. Let's try and figure out what happened and how we can fix it. I think the error was my fault.

We didn't upload any of the localized the banners onto the dev site (as there were almost 200 of them), but we should have run them past you to double check. 

However, I know where the error happened. Prior to launch I was able to get a designer to lay out the localized buttons using the Meta font. We hadn't thought that we'd be able to do this, which is why we'd asked for localizers to help us out. Most of the localizers didn't have the software to do it and we were quite stuck. You had very kindly laid out the buttons before this using a font very close to it. When we were actually able to get the buttons laid out, I used the translation from the etherpad, not the translation you had provided in the buttons you laid out. Again, this should have been run past you to confirm that it had been done correctly. 

This whole situation really adds to the need for us to use an open font, but that is a conversation for another bug. 

I am very sorry for this. 

In terms of getting it corrected as quickly as we can, is it only the Firefox for Android button that it is incorrect? Or are there errors in the Firefox for Desktop and Firefox plugin buttons?

Please let me know as soon as you can. I will get them corrected and confirmed with you as soon as I can and we can get the corrected buttons uploaded asap.
(In reply to Chelsea Novak [:chelsea] from comment #12)
> Peter, 
> 
> The content for the buttons, we took the translation from this etherpad not
> from verbatim: https://etherpad.mozilla.org/ff-mobilebuttons-l10n
> 

Chelsea, 

I know those strings were pulled from etherpad, but the comment 7 & 8 were talking about the issue of navigation bar of in header. 

I've tried for many locales and every of them are still showing "DESKTOP" no matter what the language is. Hence the comment 8 indicated the description of both "Desktop" and "Mobile" two strings in contrast on Verbatim  :)
BTW, I can confirm the problem affects the buttons for Firefox Mobile only. 

For the buttons of Plugin Check, there's a issue that we have different styles of punctuation marks, "," for comma and "。" for periods. Removing these marks is welcomed but this is a not-that-big problem.
Peter, 

If it's the header, then I'll ping Milos and mkelly about it and see how we fix that. I think we'll need to file a separate bug to sort that out as it relates to the site and not the buttons themselves (if I am understanding you correctly).

Can you confirm for the that the characters are correct in the first comment on this bug so we can get the images corrected? I don't want to make the same mistake twice.

Thanks!
Chelsea
The header is a code issue; the word Desktop isn't run through the localization function: https://github.com/mozilla/django-moz-header/blob/unified/header.html#L11

Filing a bug and attaching it to the 1.1 milestone is your best bet for getting that out.
Sure, the characters are correct.

But since I couldn't tell the difference of fonts used between Irvin's and the current artwork, would it be easier for you to use one or some of the files he provided? It came with a better translation and layout design of sentences.

Text below are what he provided:
======
Android 版 Firefox 立即下載 (mobile_dl_125x125_*.png)

你的網路如影隨形 Android 版 Firefox 立即下載 (mobile_dl_*_*_1.png), 

出門別忘帶上你的網路 Android 版 Firefox 立即下載 (mobile_dl_*_*_2.png)

網路帶著就走 Android 版 Firefox 立即下載 (mobile_dl_*_*_3.png)
======


Thanks :)
Sure. You're good with the fonts not matching the rest of the buttons though?
Okay, we are uploading them to production. Thanks for your help!
(In reply to Chelsea Novak [:chelsea] from comment #18)
> Sure. You're good with the fonts not matching the rest of the buttons though?

Yes, I just compared with the firefox mobile buttons.

(In reply to Chelsea Novak [:chelsea] from comment #19)
> Okay, we are uploading them to production. Thanks for your help!

Thanks a lot, too!
Hi Peter, 

I need help with one more thing. We didn't use all the buttons for launch. Can you confirm that these buttons that I'm linking too match the ones that are live on the site?

http://cl.ly/1L2Z3f1X3B400V2b2c2q
http://cl.ly/0200423j2u3l423B0Z25
http://cl.ly/39192V0x172n072U1009
http://cl.ly/2X2R1b1O0H0o3d3V1c1V
http://cl.ly/28112l1J1w0z2a2p1f0K

Thanks!
Chelsea

Comment 22

7 years ago
(In reply to Peter Pin-Guang Chen [:petercpg] (MozTW.org) from comment #17)
> Sure, the characters are correct.
> 
> But since I couldn't tell the difference of fonts used between Irvin's and
> the current artwork, would it be easier for you to use one or some of the
> files he provided? It came with a better translation and layout design of
> sentences.
> 
> Text below are what he provided:
> ======
> Android 版 Firefox 立即下載 (mobile_dl_125x125_*.png)
> 
> 你的網路如影隨形 Android 版 Firefox 立即下載 (mobile_dl_*_*_1.png), 
> 
> 出門別忘帶上你的網路 Android 版 Firefox 立即下載 (mobile_dl_*_*_2.png)
> 
> 網路帶著就走 Android 版 Firefox 立即下載 (mobile_dl_*_*_3.png)
> ======
> 
> 
> Thanks :)

I think the localization for a slogan is not basically translate any word, but to tell the thought we want to say. Thus the translate of mine and etherpad one is different. Also the font I'd choose to match the meaning of the slogan.

The translate of Firefox for desktop and plugin one is not really well, especially the content of plugin one. There have been several ppls ask me what's the meaning of "Groom Parrot" and why it's associate with plugin. I think we'd to figure out the better localization content for that one, and it's not only needed for zhtw, for all the locale.
(In reply to Chelsea Novak [:chelsea] from comment #21)
> Hi Peter, 
> 
> I need help with one more thing. We didn't use all the buttons for launch.
> Can you confirm that these buttons that I'm linking too match the ones that
> are live on the site?
> 
> http://cl.ly/1L2Z3f1X3B400V2b2c2q
> http://cl.ly/0200423j2u3l423B0Z25
> http://cl.ly/39192V0x172n072U1009
> http://cl.ly/2X2R1b1O0H0o3d3V1c1V
> http://cl.ly/28112l1J1w0z2a2p1f0K
> 
> Thanks!
> Chelsea


Yes, they all correct images matching to the ones alive, except the 160*600 blue one isn't here.

Comment 24

7 years ago
(In reply to Chelsea Novak [:chelsea] from comment #21)
> Hi Peter, 
> 
> I need help with one more thing. We didn't use all the buttons for launch.
> Can you confirm that these buttons that I'm linking too match the ones that
> are live on the site?
> 
> http://cl.ly/1L2Z3f1X3B400V2b2c2q
> http://cl.ly/0200423j2u3l423B0Z25
> http://cl.ly/39192V0x172n072U1009
> http://cl.ly/2X2R1b1O0H0o3d3V1c1V
> http://cl.ly/28112l1J1w0z2a2p1f0K
> 
> Thanks!
> Chelsea

Confirm for that. You can also get mobile_dl_125x125_color for the smallest one for mobile.
Thank you both. There's only one version of the 125x125 so no guessing needed there.

and yes Irvin, the plugin ones is really awkward to translate. I don't think we'll be making buttons in the style or if we do, we'll supply a simple english version to localize. 

Thanks again!

Comment 26

7 years ago
I've uploaded 9 of the new zh-TW banners to production. Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Bumping to qa verified per comment 25 and comment 26.
Status: RESOLVED → VERIFIED
OS: Linux → All
Hardware: x86 → All
Whiteboard: [l10n][qa-]
(Reporter)

Updated

7 years ago
Summary: [zh-TW] Affiliates program: mobile and plugins banners localization → [zh-TW][mobile][plugin Affiliates program: mobile and plugins banners localization
(Reporter)

Comment 28

7 years ago
Moving to proper category and adjusting the page title so that affiliates banners dashboard can fetch and parse this bug properly.
Component: affiliates.mozilla.org → affiliates.mozilla.org banners
QA Contact: affiliates-mozilla-org → affiliates-mozilla-org-banners
Summary: [zh-TW][mobile][plugin Affiliates program: mobile and plugins banners localization → [zh-TW][mobile][plugin] Affiliates program: mobile and plugins banners localization
(Assignee)

Updated

6 years ago
Product: Websites → Firefox Affiliates
(Assignee)

Updated

3 years ago
Product: Firefox Affiliates → Firefox Affiliates Graveyard
You need to log in before you can comment on or make changes to this bug.