Last Comment Bug 685465 - js\src\jsobj.h(333) : warning C4099: 'js::GlobalObject' : type name first seen using 'struct' now seen using 'class'
: js\src\jsobj.h(333) : warning C4099: 'js::GlobalObject' : type name first see...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: mozilla9
Assigned To: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-08 01:40 PDT by Makoto Kato [:m_kato]
Modified: 2011-09-28 23:01 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (371 bytes, patch)
2011-09-08 06:21 PDT, Makoto Kato [:m_kato]
bhackett1024: review+
Details | Diff | Review

Description Makoto Kato [:m_kato] 2011-09-08 01:40:00 PDT
After recent TI/JM merging, this warning hits on warnaserr.

https://tbpl.mozilla.org/php/getParsedLog.php?id=6325531&full=1

d:/mozilla-build/python25/python2.5.exe -O e:/builds/moz2_slave/m-in-w32-dbg/build/js/src/build/cl.py cl -Fojsapi.obj -c   -DOSTYPE=\"WINNT5.2\" -DOSARCH=WINNT -DEXPORT_JS_API -DIMPL_MFBT -DJS_HAS_CTYPES -DDLL_PREFIX=\"\" -DDLL_SUFFIX=\".dll\" -Ictypes/libffi/include -I.  -I/e/builds/moz2_slave/m-in-w32-dbg/build/js/src -I. -I./../../dist/include -I./../../dist/include/nsprpub  -Ie:/builds/moz2_slave/m-in-w32-dbg/build/obj-firefox/dist/include/nspr  -I/e/builds/moz2_slave/m-in-w32-dbg/build/js/src -I/e/builds/moz2_slave/m-in-w32-dbg/build/js/src/assembler -I/e/builds/moz2_slave/m-in-w32-dbg/build/js/src/yarr    -GR- -TP -nologo -wd4345 -D_CRT_SECURE_NO_WARNINGS -W3 -Gy -Fdgenerated.pdb -wd4244 -wd4800 -we4553  -DDEBUG -D_DEBUG -DTRACING -Zi -Oy- -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1 -MDd           -FI ./js-confdefs.h -DMOZILLA_CLIENT /e/builds/moz2_slave/m-in-w32-dbg/build/js/src/jsapi.cpp
jsapi.cpp

e:\builds\moz2_slave\m-in-w32-dbg\build\js\src\jsobj.h(333) : warning C4099: 'js::GlobalObject' : type name first seen using 'struct' now seen using 'class'

        e:\builds\moz2_slave\m-in-w32-dbg\build\js\src\jsinfer.h(58) : see declaration of 'js::GlobalObject'

e:\builds\moz2_slave\m-in-w32-dbg\build\js\src\vm/GlobalObject.h(81) : warning C4099: 'js::GlobalObject' : type name first seen using 'struct' now seen using 'class'

        e:\builds\moz2_slave\m-in-w32-dbg\build\js\src\jsinfer.h(58) : see declaration of 'js::GlobalObject'
Comment 1 Makoto Kato [:m_kato] 2011-09-08 06:21:50 PDT
Created attachment 559133 [details] [diff] [review]
fix
Comment 2 Makoto Kato [:m_kato] 2011-09-28 23:01:54 PDT
this was fixed by the following.  mark as resolved due to no bug.

changeset:   76739:f6d9507d6f6e
user:        Kyle Huey <khuey@kylehuey.com>
date:        Thu Sep 08 13:22:20 2011 -0400
summary:     Fix MSVC build warning (no bug). rs=bhackett

Note You need to log in before you can comment on or make changes to this bug.