Crash [@ nsRegion::Or] with position:fixed, float, filter, etc

RESOLVED DUPLICATE of bug 591304

Status

()

RESOLVED DUPLICATE of bug 591304
7 years ago
3 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({crash, regression, testcase})

Trunk
x86
Windows 7
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 559131 [details]
testcase

I had this case lying around, it seems like I never filed a bug for it.
It might be possible that the testcase could be simplified further, I haven't tried it.

Not sure when it regressed. The testcase is from 27-08-2010, so it should at least crash from around that time, still.

https://crash-stats.mozilla.com/report/index/409c5423-51cd-4af2-80e4-28d092110907
0 	xul.dll 	nsRegion::Or 	gfx/src/nsRegion.cpp:782
1 	xul.dll 	nsRegion::Or 	gfx/src/nsRegion.cpp:798
2 	xul.dll 	nsViewManager::UpdateWidgetArea 	view/src/nsViewManager.cpp:515
3 	xul.dll 	nsIFrame::InvalidateInternal 	layout/generic/nsFrame.cpp:4348
4 	xul.dll 	nsIFrame::InvalidateInternal 	layout/generic/nsFrame.cpp:4348
5 	xul.dll 	nsIFrame::InvalidateInternal 	layout/generic/nsFrame.cpp:4348
6 	xul.dll 	nsIFrame::InvalidateInternal 	layout/generic/nsFrame.cpp:4348
7 	xul.dll 	nsIFrame::InvalidateInternal 	layout/generic/nsFrame.cpp:4348
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591304
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.