Closed Bug 685549 Opened 8 years ago Closed 8 years ago

[Tablet] Transparent rectangular over tabs open in new tab

Categories

(Firefox for Android Graveyard :: General, defect)

Firefox 9
ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 9

People

(Reporter: ioana.chiorean, Assigned: mbrubeck)

References

Details

Attachments

(3 files)

Build id : Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110908
Firefox/9.0a1 Fennec/9.0a1
Device: Acer Iconia A500
OS: Android 3.1

Steps to reproduce:
1. Open Fennec app 
2. Load a site for news ex nypost.com
3. Open in a new tab a link from the loaded tab
4. Look in tab panel

Expected result:
At step 4, tabs should look like in the mock-up http://cl.ly/47102P131N0L1G2y0W1M (from ibarlow)

Actual result:
At step 4 there is present a transparent rectangular over the opened in new tab tabs.

Note : please see the attached screenshot
Assignee: nobody → mbrubeck
Blocks: 680077
Status: NEW → ASSIGNED
Version: Trunk → Firefox 9
Attached patch patchSplinter Review
It looks like the observer attribute is not getting set quickly enough on the documenttab itself, or something.  In any case, it's not matching the [tablet="true"] styles when it's first created.  Matching based on the container works.
Attachment #559306 - Flags: review?(wjohnston)
Attached patch patch 2Splinter Review
Not directly related, just some code cleanup.  Use [tablet] instead of [tablet="true"] for brevity, and remove an empty rule that snuck in by accident.
Attachment #559307 - Flags: review?(wjohnston)
Attachment #559306 - Flags: review?(wjohnston) → review+
Attachment #559307 - Flags: review?(wjohnston) → review+
http://hg.mozilla.org/mozilla-central/rev/53cc48edabba
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → Firefox 9
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110927
Firefox/9.0a1 Fennec/9.0a1
Device: Acer ICONIA A500
OS: Android 3.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.