Use production-masters.json as the default for setup-masters.py

RESOLVED FIXED

Status

Release Engineering
General
P3
normal
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: armenzg, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 559257 [details] [diff] [review]
modify setup_masters.py to load the production-masters.json file rather than the masters_08 list

I was trying to setup the bm16-tests1-windows master and I realized that it wasn't on the list of ./setup_masters.py.

Then I figured out that an out of date list of masters was being use (masters_08) instead of the up to date list that the json files provides.

I have not being able to find any other file besides Makefile.setup that a default setting change would be affected.

From looking at preproduction [1] I don't see bm16-tests1-windows and other recent masters being tested.

[1] http://preproduction-master.build.mozilla.org:8710/builders/test-masters/builds/2630/steps/test_masters/logs/stdio
Attachment #559257 - Flags: review?(rail)
Attachment #559257 - Flags: review?(catlee)
(Assignee)

Updated

7 years ago
Priority: -- → P3
(Assignee)

Updated

7 years ago
Status: NEW → ASSIGNED

Updated

7 years ago
Attachment #559257 - Flags: review?(catlee) → review+
(Assignee)

Comment 1

7 years ago
rail: ping for r? please :)
Attachment #559257 - Flags: review?(rail) → review+
(Assignee)

Comment 2

7 years ago
Comment on attachment 559257 [details] [diff] [review]
modify setup_masters.py to load the production-masters.json file rather than the masters_08 list

http://hg.mozilla.org/build/buildbot-configs/rev/eb6d4cc57da9
Attachment #559257 - Flags: checked-in+
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.