If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SMTP errors since version 5.0

RESOLVED INVALID

Status

MailNews Core
Networking: SMTP
RESOLVED INVALID
6 years ago
5 months ago

People

(Reporter: sentix001, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.220 Safari/535.1

Steps to reproduce:

Hi, since version 5.0 there has been a problem sending email, receiving is ok. 
A search on the internet leads me to beleive i'm not the only one. 
Last working version was 3.1.12 anything after doesn't work including version 6.0 + 6.1 

Problem is as follows: Thunderbird connects to the smtp server says connected, so connectivity is not an issue, then fails without a reason. Reinstalling 3.1.12 fixes the problem so it's an issue with the client. 
The server is our own work server hosted on a dedicated server, no other clients have this problem( Outlook, iPhone, Nokia Mobile Email) so it's not from the server. 

I hope you manage to fix this as our company always relied on your products but seems this has to change as 3 releases after still no fix. 

Thanks


Actual results:

Failed without reason


Expected results:

Mail should have sent normally
(Reporter)

Updated

6 years ago
See Also: → bug 617172
Please provide a smtp log 
https://wiki.mozilla.org/MailNews:Logging
(Reporter)

Comment 2

6 years ago
0[72d140]: SMTP Connecting to: mail.easydna.net
0[72d140]: SMTP entering state: 0
0[72d140]: SMTP Response: 220 mail.dnatestingaustralia.net ESMTP
0[72d140]: SMTP entering state: 14
0[72d140]: SMTP Send: EHLO [10.0.20.57]

0[72d140]: SMTP entering state: 0
0[72d140]: SMTP Response: 250-mail.dnatestingaustralia.net
0[72d140]: SMTP entering state: 0
0[72d140]: SMTP Response: 250-STARTTLS
0[72d140]: SMTP entering state: 0
0[72d140]: SMTP Response: 250-PIPELINING
0[72d140]: SMTP entering state: 0
0[72d140]: SMTP Response: 250-8BITMIME
0[72d140]: SMTP entering state: 0
0[72d140]: SMTP Response: 250-SIZE 20971520
0[72d140]: SMTP entering state: 0
0[72d140]: SMTP Response: 250 AUTH LOGIN PLAIN
0[72d140]: SMTP entering state: 4
0[72d140]: SMTP entering state: 21
0[72d140]: SMTP Send: STARTTLS

0[72d140]: SMTP entering state: 0
0[72d140]: SMTP Response: 220 ready for tls
0[72d140]: SMTP entering state: 19
0[72d140]: SMTP entering state: 14
0[72d140]: SMTP Send: EHLO [10.0.20.57]
(Reporter)

Comment 3

6 years ago
thats a failed sent email, with thunderbird stating timed out
(Reporter)

Comment 4

6 years ago
One thing I need to add also, is that from 30 emails, one of them managed to send so it's not completely unsendable
(Reporter)

Comment 5

6 years ago
0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 250-mail.dnatestingaustralia.net
0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 250-PIPELINING
0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 250-8BITMIME
0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 250-SIZE 20971520
0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 250 AUTH LOGIN PLAIN
0[3126140]: SMTP entering state: 4
0[3126140]: SMTP entering state: 21
0[3126140]: SMTP auth: server caps 0x10310, pref 0x300, failed 0x0, avail caps 0x300
0[3126140]: (GSSAPI = 0x800, CRAM = 0x2000, NTLM = 0x4000, MSN =  0x8000, PLAIN = 0x200, LOGIN = 0x100, EXTERNAL = 0x400)
0[3126140]: trying auth method 0x200
0[3126140]: SMTP entering state: 16
0[3126140]: SMTP AuthLoginStep1() for stefan@easydna.net@
0[3126140]: PLAIN auth
0[3126140]: Logging suppressed for this command (it probably contained authentication information)
0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 235 ok, go ahead (#2.0.0)
0[3126140]: SMTP entering state: 18
0[3126140]: SMTP Login response, code 235
0[3126140]: SMTP entering state: 3
0[3126140]: SMTP Send: MAIL FROM:<stefan@easydna.net> SIZE=411

0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 250 ok
0[3126140]: SMTP entering state: 5
0[3126140]: SMTP Send: RCPT TO:<stefan@easydna.net>

0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 250 ok
0[3126140]: SMTP entering state: 6
0[3126140]: SMTP Send: DATA

0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 354 go ahead
0[3126140]: SMTP entering state: 7
0[3126140]: SMTP entering state: 8
0[3126140]: SMTP Send: .

0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 250 ok 1315559635 qp 29814
0[3126140]: SMTP entering state: 9
0[3126140]: SMTP Send: QUIT

0[3126140]: SMTP entering state: 0
0[3126140]: SMTP entering state: 0
0[3126140]: SMTP Response: 221 mail.dnatestingaustralia.net
0[3126140]: SMTP entering state: 10
0[3126140]: SMTP entering state: 12

_________________________________________________________________
This is a log of successfully sent mail using version 3.1.12
Thunderbird gets no response from the server after the EHLO command.
Do you have AV software or third party firewalls installed that could cause this ?
It would be better if you attach the complete logs as file.

Did you try to "play" with the security settings in Tools/Account settings/Outgoing Server/Server->Edit ?
Component: General → Networking: SMTP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.smtp
(Reporter)

Comment 7

6 years ago
not at all, both logs, the successful and unsuccessful one were sent from the SAME PC, not firewalled, and same thunderbird settings: process was as follows

Install thunderbird 3.1.12 -> try send successful
Upgrade to 6.1 -> try send unsuccessful 19 times out of 20
Install back 3.1.12 over 6.1 -> try send successful
sentix, are you still seeing this when using newer version?
(Reporter)

Comment 9

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #8)
> sentix, are you still seeing this when using newer version?

Yes I just tested, still happens with version 11. We use this at work and because of this problem we still have around 50 employees working with version 3 as that's the last version which doesn't cause problems

Comment 10

6 years ago
Working condition is bit different it doesn't use STARTTLS, so I recomend to disable it and try again on 11 version. Also can you confirm do you have any AV installed on this machine? Because some outdate version antiviures can cause problem with starttls.
sentix...

(In reply to Nikolay Shopik from comment #10)
> Working condition is bit different it doesn't use STARTTLS, so I recomend to
> disable it and try again on 11 version. Also can you confirm do you have any
> AV installed on this machine? Because some outdate version antiviures can
> cause problem with starttls.
Flags: needinfo?(sentix001)
Whiteboard: [closeme 2012-12-01]
(Reporter)

Comment 12

5 years ago
will get back to you shortly
Flags: needinfo?(sentix001)
(Reporter)

Comment 13

5 years ago
seems sorted though emails take quite a lot to go out
10 secs to 15 s

Yes i have a NOD32 updated latest version but i also disabled it for the test

Updated

5 years ago
Whiteboard: [closeme 2012-12-01]
It's been a long time - I'm hoping you no longer see this.
Which in any event doesn't sound like a problem caused by Thunderbird
Whiteboard: [closeme 2017-04-01 INVALID]

Comment 15

5 months ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INVALID
Whiteboard: [closeme 2017-04-01 INVALID]
You need to log in before you can comment on or make changes to this bug.