AVM2 Specification in Doxygen format

RESOLVED FIXED in Q1 12 - Brannan

Status

Tamarin
Documentation
P3
normal
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Andre Kruetzfeldt, Assigned: Edwin Smith)

Tracking

(Blocks: 2 bugs)

unspecified
Q1 12 - Brannan
x86
Mac OS X
Dependency tree / graph
Bug Flags:
flashplayer-qrb +

Details

(Whiteboard: loose-end)

Attachments

(5 attachments, 11 obsolete attachments)

615.46 KB, patch
Details | Diff | Splinter Review
2.79 KB, patch
Details | Diff | Splinter Review
70.96 KB, patch
Details | Diff | Splinter Review
3.15 KB, patch
Details | Diff | Splinter Review
277 bytes, patch
Details | Diff | Splinter Review
(Reporter)

Description

7 years ago
This is the additional AVM2 specification that hosts the byte code and describes the overall architecture. It replaces the "old" pdf AVM2Overview.

Comment 1

7 years ago
jsudduth: Once this gets pushed we should modify the build/buildbot/slaves/all/build-doxygen.sh script to generate this document as well and also post it to http://tamarin-builds.mozilla.org/doxygen/html/
Flags: flashplayer-qrb?
(Reporter)

Comment 2

7 years ago
Created attachment 559492 [details] [diff] [review]
Initial avmspec patch
Attachment #559492 - Flags: review?(edwsmith)
(Reporter)

Comment 3

7 years ago
Brent/James: I'll have another patch by COB that will cleanup and generate the html directory, so that developers can generate the material.
(Reporter)

Comment 4

7 years ago
Created attachment 559623 [details] [diff] [review]
Updated now including abcfile format

Comment 5

7 years ago
Looking for a review or feedback?
Flags: flashplayer-qrb? → flashplayer-qrb+
Priority: -- → P3
Whiteboard: loose-end
Target Milestone: --- → Q1 12 - Brannan
(Reporter)

Comment 6

7 years ago
Created attachment 559867 [details] [diff] [review]
Format fixes
Attachment #559492 - Attachment is obsolete: true
Attachment #559623 - Attachment is obsolete: true
Attachment #559492 - Flags: review?(edwsmith)
(Reporter)

Updated

7 years ago
Attachment #559867 - Attachment is patch: true
(Reporter)

Comment 7

7 years ago
Created attachment 559871 [details] [diff] [review]
avm spec incl. fix for 567107

Now including https://bugzilla.mozilla.org/show_bug.cgi?id=567107
Attachment #559867 - Attachment is obsolete: true
(Reporter)

Comment 8

7 years ago
Created attachment 559872 [details] [diff] [review]
avm spec incl. fix for 557640
Attachment #559871 - Attachment is obsolete: true
(Reporter)

Comment 9

7 years ago
Created attachment 559873 [details] [diff] [review]
avm spec including fix for 623725

All avm spec bugs included and unneeded generated code removed. Closing https://bugzilla.mozilla.org/show_bug.cgi?id=623725
Attachment #559872 - Attachment is obsolete: true
Attachment #559873 - Flags: review?(edwsmith)
(Reporter)

Comment 10

7 years ago
After R+ ready to land as third patch. Passing bug to Edwin for landing.
Assignee: akruetzf → edwsmith
(Assignee)

Comment 11

7 years ago
Is this bug the "official" dupe of bug 416391?  If so, can close bug 416391.
(Reporter)

Comment 12

7 years ago
bug 416391 morphed into my tracking bug. But this one has to land as the "mega-patch".
(Assignee)

Updated

7 years ago
Blocks: 416391
(Assignee)

Updated

7 years ago
Depends on: 646541
(Assignee)

Updated

7 years ago
Blocks: 646541
No longer depends on: 646541
(Assignee)

Updated

7 years ago
Attachment #559873 - Attachment description: avm spec incl. fix for 623725 → avm spec including fix for 623725
Attachment #559873 - Attachment filename: avmspec.patch → avmspec-patch
(Assignee)

Comment 13

7 years ago
Whats here looks right, and its nice to see the full chapter 4.

the patch adds two doxyfiles:
  doc/avmspec/spec.doxyfile
  doc/spec.doxyfile

These appear unchanged (no problem)
  doc/bytecode/...
  doc/bytecode.doxyfile

If I run:
 $ cd doc/avmspec
 $ doxygen spec

Then I get a spec dir with html and latex, which doesn't contain the bytecode
descriptions.  

If I run:
 $ cd doc
 $ doxygen spec

I get:
warning: tag INCLUDE_PATH: include path `doc/avmspec/bytecode' does not exist
warning: tag INPUT: input source `doc/avmspec/legal.dox' does not exist
... and so on, then
error: tag OUTPUT_DIRECTORY: Output directory `docs/spec' does not exist and cannot be created
Exiting...

So, could add a README or something to the patch that makes it clear how to
generate the full spec content?  mainly: where to cd, what command to run.
(Assignee)

Updated

7 years ago
Attachment #559873 - Flags: review?(edwsmith) → review-
(Reporter)

Comment 14

7 years ago
I'll plan to add a script that does all the clean up and generation when I do have all doc files done.
(Reporter)

Comment 15

7 years ago
Created attachment 560229 [details]
Updated spec file

Updated spec.doxyfile, now generating the spec in doc/docs/...
Attachment #560229 - Flags: review?(edwsmith)
(Assignee)

Comment 16

7 years ago
Created attachment 560232 [details] [diff] [review]
Replace doc/spec.doxyfile, remove doc/bytecode.doxyfile, remove doc/avmspec/spec.doxyfile
Attachment #560232 - Flags: feedback?(akruetzf)
(Assignee)

Updated

7 years ago
Attachment #560229 - Attachment is obsolete: true
Attachment #560229 - Flags: review?(edwsmith)
(Reporter)

Comment 17

7 years ago
That is correct.

(In reply to Edwin Smith from comment #16)
> Created attachment 560232 [details] [diff] [review]
> Replace doc/spec.doxyfile, remove doc/bytecode.doxyfile, remove
> doc/avmspec/spec.doxyfile
(Reporter)

Comment 18

7 years ago
Created attachment 560277 [details]
Spec file with MOPS

Updates spec file to include mops instructions
(Reporter)

Comment 19

7 years ago
Created attachment 560278 [details]
create spec directory and populate with content
(Assignee)

Comment 20

7 years ago
Comment on attachment 560277 [details]
Spec file with MOPS

This belongs on bug 624221 in the form of a patch
(Reporter)

Updated

7 years ago
Attachment #560277 - Attachment is obsolete: true
(Reporter)

Comment 21

7 years ago
Spec file patch moved to 624221
(Assignee)

Updated

7 years ago
Attachment #560232 - Flags: feedback?(akruetzf) → review?(dansmith)
(Assignee)

Comment 22

7 years ago
Created attachment 560341 [details] [diff] [review]
Updated spec patch bomb

This patch subsumes all previous patches.

The main (only) doxyfile is named doc/avmspec.doxyfile.

to run: $ cd doc; doxygen avmspec.doxyfile

output goes to doc/avmspec-generated.
Attachment #559873 - Attachment is obsolete: true
Attachment #560232 - Attachment is obsolete: true
Attachment #560278 - Attachment is obsolete: true
Attachment #560232 - Flags: review?(dansmith)

Comment 23

7 years ago
The legal page contents should be replaced with this text:


Copyright © 2006–2011 Adobe Systems Incorporated. All rights reserved.

Adobe, the Adobe Logo, and ActionScript, are trademarks or registered trademarks of Adobe Systems Incorporated in the United States and/or other countries. All other trademarks are the property of their respective owners.

This publication and the information herein is furnished AS IS, is subject to change without notice, and should not be construed as a commitment by Adobe Systems Incorporated. Adobe Systems Incorporated assumes no responsibility or liability for any errors or inaccuracies, makes no warranty of any kind (express, implied, or statutory) with respect to this publication, and expressly disclaims any and all warranties of merchantability, fitness for particular purposes, and noninfringement of third party rights.

Adobe Systems Incorporated
345 Park Avenue
San Jose, CA 95110
(408) 536-6000
(Reporter)

Comment 24

7 years ago
Created attachment 560351 [details] [diff] [review]
Updated legal
(Reporter)

Comment 25

7 years ago
Created attachment 560354 [details] [diff] [review]
Legal formated

Now bold and address formatted.
Attachment #560351 - Attachment is obsolete: true
(Reporter)

Comment 26

7 years ago
Created attachment 560375 [details] [diff] [review]
adobe legal
(Reporter)

Comment 27

7 years ago
Created attachment 560377 [details] [diff] [review]
Adobe legal 2
(Reporter)

Comment 28

7 years ago
Created attachment 560379 [details] [diff] [review]
Adobe doc generate
(Assignee)

Updated

7 years ago
Blocks: 685660

Comment 29

7 years ago
changeset: 6599:da6f9fa3b354
user:      Andre Kruetzfeldt <akruetzf>
summary:   Bug 685899 - "AVM2 Specification in Doxygen format" (r=dsmith+)

http://hg.mozilla.org/tamarin-redux/rev/da6f9fa3b354
(Assignee)

Updated

7 years ago
Blocks: 689408
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.