mouseup event being eaten when synchonous ajax call is initiated on mousedown

RESOLVED DUPLICATE of bug 636171

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 636171
6 years ago
2 months ago

People

(Reporter: kerberos.1964, Unassigned)

Tracking

({testcase})

6 Branch
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I'm finding that when I do a synchronous ajax call on a mousedown event, FireFox seems to eat the mouseup event, if I release the mouse before the ajax call returns.

This is a problem for me because I have code that assumes if you move the mouse after a mousedown you are initiating a drag operation.  The abscense of the mouseup causes unwanted drag operations.

Comment 1

6 years ago
Please provide a public URL or reduced test case that exhibits this issue.

Does this occur with other browsers?

What version of Firefox are you running? Does it work in other versions?
Keywords: testcase-wanted
(Reporter)

Comment 2

6 years ago
I'm sorry, but I can't provide a simple repro...I'm working on it.  To answer your questions:

No, it doesn't happen in any other browser.

I'm using FF 6.0.2, but this has been an issue since FF 3.x

PS
I'm sorry if I'm not doing this (bug system) correctly...I've never posted here before, so I may not do things I should...and do things I shouldn't.
(Reporter)

Comment 3

6 years ago
Created attachment 559997 [details]
Show's the associated bug.

This simple file shows the problem described.

1. Create a local file which the AJAX call can retrieve (on my machine it was about 1meg)

2. Replace the dummy url in the xLoader.open call to point to your test file.

3. Load the file into FF and press/release the button quickly enough so the mouseup happens before the file AJAX call is complete.

You will see no mouseup event ever makes it to the button...and the system behaves as if the mouse is still down.
(Reporter)

Updated

6 years ago
Keywords: testcase-wanted → testcase
(Reporter)

Updated

6 years ago
Whiteboard: Is anyone ever going to look at this bug?

Comment 4

6 years ago
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Whiteboard: Is anyone ever going to look at this bug?
Version: unspecified → 6 Branch

Updated

6 years ago
Attachment #559997 - Attachment mime type: text/plain → text/html

Comment 5

4 years ago
Reduced testcase:

http://jsfiddle.net/cmcnulty/h9RDT/5/

click on the link 'test' and note that neither the mouseup nor click events are fired in firefox.  All events associated with the click are fired in IE/Chrome

Comment 6

4 years ago
Also, this is a duplicate of #636171

Updated

2 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636171
You need to log in before you can comment on or make changes to this bug.