Closed Bug 686029 Opened 9 years ago Closed 8 years ago

probably not a bug - images .JPG are not recognized

Categories

(Firefox :: General, defect)

6 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: jiri.hlavka, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

open http://christina-hendricks.net/gallery/


Actual results:

server side serves images with text/html heads - Firefox not recognized images


Expected results:

display .JPG images
The images seem to work with Seamonkey trunk on win32
WFM - Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110909 Firefox/9.0a1 ID:20110909030839

Can you attach a screenshot of what you are seeing?
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
(In reply to Tim (fmdeveloper) from comment #4)
> Does the issue still occur if you start Firefox in Safe Mode?
> http://support.mozilla.com/en-US/kb/Safe+Mode

Safe mode did not help,

> How about with a new, empty profile?
> http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-
> profile

but the new profile helped to correct.
Please start with your old profile and on the page use shift+reload(button) to do a forced reload.
(In reply to Matthias Versen (Matti) from comment #6)
> Please start with your old profile and on the page use shift+reload(button)
> to do a forced reload.

Neither the repeated force reload did not help.
I see the same problem as the screenshot, on Win XP, 32bit, Ff6.0.2. IE8 displays the images fine. However, isn't Firefox behaviour correct, if the server sends wrong mime type?
(In reply to aceman from comment #8)
> I see the same problem as the screenshot, on Win XP, 32bit, Ff6.0.2. IE8
> displays the images fine. However, isn't Firefox behaviour correct, if the
> server sends wrong mime type?

Yes, MIME is wrong, but specifically this combination text / html and binary file can be uniquely identified.
>MIME is wrong, but specifically this combination text / html and binary file can be uniquely identified.

That would be a violation of the http rfc and how about UTF-16 ?
This bug is invalid if they really send the wrong mime-type.

The images are "link protected" and you get a http 302->http 403 if you don't send a http referrer header. With http referrer the site sends images as "Content-Type: image/jpeg".

How do you got the text/html information ?
(In reply to Matthias Versen (Matti) from comment #10)
> >MIME is wrong, but specifically this combination text / html and binary file can be uniquely identified.
> 
> That would be a violation of the http rfc and how about UTF-16 ?
> This bug is invalid if they really send the wrong mime-type.
> 
> The images are "link protected" and you get a http 302->http 403 if you
> don't send a http referrer header. With http referrer the site sends images
> as "Content-Type: image/jpeg".
> 
> How do you got the text/html information ?

I am very sorry for the inaccuracy. I think this situation can only estimate the MIME type.
George -> Is this issue resolved? As I read the bug report this is a site error - have you contacted the site?
(In reply to Tim (fmdeveloper) from comment #12)
> George -> Is this issue resolved? As I read the bug report this is a site
> error - have you contacted the site?

The problem is solved. Thanks!
Thanks for posting back
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.