We need to add Alex Fowler to the speaker bios page

RESOLVED WONTFIX

Status

Websites
blog.mozilla.org
RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: Shannon Prior, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Hi there - please add alex fowler to the spokesperson bios page on http://www.mozilla.org/en-US/press/bios/

Alex Fowler
Global Privacy & Public Policy Lead

Alex built his first Web page in 1993 and it inspired him to shift career focus
from bioethics to Internet-related ethical and policy issues. Today, as Global
Privacy & Public Policy Lead, Alex is responsible for leading Mozilla's
strategic and operational initiatives on privacy and information management, as
well as overseeing the organization's public policy activities. Bioethics’ loss
was — and continues to be — the Web’s gain.

With more than 20 years of experience, Alex is a dedicated professional focused on consumer rights, privacy by design and data governance. Alex's past experience includes roles with Zero-Knowledge Systems, the Electronic Frontier Foundation and the American Association for the Advancement of Science. Most recently, Alex served as a leader of PwC's privacy practice, where he advised more than 50 organizations spanning finance, technology and healthcare industries.

Alex holds degrees from Brown University and George Washington University. He
is also a professionally trained cellist and amate
(Reporter)

Comment 1

6 years ago
His photo is here: http://www.sendspace.com/file/bl00qa 

THANK YOU!
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Updated

5 years ago
Component: General → blog.mozilla.org
OS: Mac OS X → All
Product: www.mozilla.org → Websites
Hardware: x86 → All

Comment 2

3 years ago
Hi Craig I know this is a old bug 

Can you please add this or blog for the correct person
Flags: needinfo?(craigcook.bugz)
I'm pretty sure this is no longer relevant.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(craigcook.bugz)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.