Open Bug 686125 Opened 8 years ago Updated 6 years ago

GPU info is incorrect in about:support and [Help][Troubleshooting Information].

Categories

(Core :: Graphics, defect, minor)

9 Branch
x86
Windows XP
defect
Not set
minor

Tracking

()

REOPENED

People

(Reporter: rob1weld, Unassigned)

References

Details

If I use [Help][Troubleshooting Information] or type about:support it says:

"
...
Graphics
Adapter Description		NVIDIA GeForce GTS 250
Vendor ID			10de
Device ID			0615
Adapter RAM			Unknown
Adapter Drivers			nv4_disp
Driver Version			6.14.12.8019
Driver Date			7-23-2011
Vendor ID (GPU #2)		10de
Device ID (GPU #2)		0241
Adapter RAM (GPU #2)		Unknown
Adapter Drivers (GPU #2)	Unknown
Driver Version (GPU #2)		8.2.0.5
Driver Date (GPU #2)		1-24-2006
WebGL Renderer			Google Inc. -- ANGLE (NVIDIA GeForce GTS 250) -- OpenGL ES 2.0 (ANGLE 0.0.0.740)
GPU Accelerated Windows		2/2 Direct3D 9
".

I only have one GPU, therefore the references to the second GPU are not only incorrect but the (untitled) "Value" fields are filled with incorrect values for the second GPU (which I do not have).

-----

In Bug 681613 (on 2011-08-24) "Dimas" has a "ATI Radeon HD 4550" and "Firefox/7.0 Build ID: 20110816154714" CLAIMS:
1. This user's Video Card has TWO GPUs, but it only has one.
2. FF shows different "Adapter Drivers" for "GPU" and "GPU #2".
3. And it shows "Driver Version" and "Driver Date" for 'both' GPUs as the same - whereas mine are shown to be different (FF gets it wrong for both of us).

"
...
Graphics
Adapter Description		ATI Radeon HD 4550
Vendor ID			1002
Device ID			9540
Adapter RAM			256
Adapter Drivers			aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version			8.812.0.0
Driver Date			1-4-2011
Vendor ID (GPU #2)		1002
Device ID (GPU #2)		68f9
Adapter RAM (GPU #2)		512
Adapter Drivers (GPU #2)	aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version (GPU #2)		8.812.0.0
Driver Date (GPU #2)		1-4-2011
Direct2D Enabled		false
DirectWrite Enabled		false (6.1.7600.16699)
ClearType Parameters		ClearType parameters not found
WebGL Renderer			Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU Accelerated Windows		0/1
"

-----

In Bug 667437 (on 2011-06-27) "emma.discovery@yahoo.com" has a "Intel(R) HD Graphics" and (apparently) a "Nvidia NVS 3100M" but "Firefox/5.0 Build ID: 20110615151330" CLAIMS:
1. This user has ONE Video Card with ONE GPU, yet they have two 'Cards' with one GPU each.

"
...
Graphics
Adapter Description		Intel(R) HD Graphics
Vendor ID			8086
Device ID			0046
Adapter RAM			Unknown
Adapter Drivers			igxprd32
Driver Version			6.14.10.5322
Driver Date			12-22-2010
Direct2D Enabled		false
DirectWrite Enabled		false (0.0.0.0, font cache n/a)
WebGL Renderer			Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows		0/1
"

-----

When viewing URL https://support.mozilla.com/en-US/questions/866794 (and click on Link "more system details") I see that user "Kamekai" has "Firefox 8.0a2" and it is CLAIMED:
1. That the person has 2 GPUs.
2. The amount of RAM is unknown.
3. That "Adapter Drivers (GPU #2)" is "Unknown", yet the "Driver Version (GPU #2)" is known and different from "Driver Version" and both with the same "Driver Date".

"
...
Graphics
Adapter Description		ATI Mobility Radeon X1300
Vendor ID			1002
Device ID			7149
Adapter RAM			Unknown
Adapter Drivers			ati2dvag
Driver Version			8.261.0.0
Driver Date			5-23-2006
Vendor ID (GPU #2)		000e
Device ID (GPU #2)		000e
Adapter RAM (GPU #2)		Unknown
Adapter Drivers (GPU #2)	Unknown
Driver Version (GPU #2)		7.1.542.0
Driver Date (GPU #2)		5-22-2006
WebGL Renderer			Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
GPU Accelerated Windows		0/1. Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
"

-----


There are four examples of where the number of GPUs is guessed incorrectly, and (likely) incorrect values are given where; it is speculated that the person has a second GPU (even though they do not). In the one case where the person DOES have a second GPU it is not mentioned (nor are values given for it).


We need to determine:
1. The correct number of Video Cards.
2. The correct number of GPUs on each.
3. The correct "Adapter Drivers" for each Video Card and GPU.
4. The correct Driver version and date.
5. Any other info and display the correct values.


Remember it is possible to have two (or more) different Manufacturers of GPUs (both an AMD, NVidia, Intel GPU, and other) and for each 'Card' (or APU) to have a different number of GPUs. See: http://www.lucidlogix.com/ .


We should say "Unknown" where it is not known and "Not Present" where it is not present. We should also not make up values or derive them incorrectly and provide false info. 

I'll set this as 'major' because we are 0 for 4 in the examples I gave. A "Test Pilot" might be in order or a checkbox to send the results in (to Mozilla) for comparison to a database.
Bug 679110 covers issues with multiple GPUs in about:support. 

Duplicate, unless this bug describes something not covered by bug 679110?
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
(In reply to Rob from comment #0)

> We need to determine:
> 1. The correct number of Video Cards.
> 2. The correct number of GPUs on each.
> 3. The correct "Adapter Drivers" for each Video Card and GPU.
> 4. The correct Driver version and date.
> 5. Any other info and display the correct values.

This is exactly what's being worked on in bug 679110. 

Note that the third example above (where about:support reports one GPU even though the user has two) is from Firefox 5, but multiple GPU detection wasn't introduced until Firefox 8 (bug 591057).
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 679110
Thanks for spotting the dupe. I searched before posting.

I think my Report does add a bit of new info but it is a dupe nonetheless.
As noted in Bug 679110, Comment 16, sometimes some of the info for a GPU (e.g Adapter RAM) is listed as "Unknown". This issue is not multiple-GPU-specific, so let's address that issue in this bug and de-dupe it from Bug 679110.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Summary: GPU quantity (and other info) is (usually?) incorrect in about:support and [Help][Troubleshooting Information]. → GPU info is incorrect in about:support and [Help][Troubleshooting Information].
(In reply to Ali Juma [:ajuma] from comment #4)
> As noted in Bug 679110, Comment 16, sometimes some of the info for a GPU
> (e.g Adapter RAM) is listed as "Unknown". This issue is not
> multiple-GPU-specific, so let's address that issue in this bug and de-dupe
> it from Bug 679110.

OK.

This Bug is about "[Help][Troubleshooting Information]" or "about:support" providing the correct information (an "Umbrella Bug" if you wish).

I'll mark this as "Depends 679110" (mutli-GPU or lack thereof).
Depends on: 679110
I still have "Adapter RAM Unknown" issue. The other Data seems to be filled in.
about:support

...
Graphics
Adapter Description	NVIDIA GeForce GTS 250
Adapter Drivers		nv4_disp
Adapter RAM		Unknown
Device ID		0x0615
DirectWrite Enabled	false (0.0.0.0)
Driver Date		2-1-2014
Driver Version		6.14.13.3259
GPU #2 Active		false
GPU Accelerated	 Windows	2/2 Direct3D 9
Vendor ID		0x10de
WebGL Renderer		Google Inc. -- ANGLE (NVIDIA GeForce GTS 250 Direct3D9 vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
...

The last post in this BR is over 1 year old. I'm just checking in to report that this Bug ("Adapter RAM") is still present. Two of the three issues reported in Comment 0 have been fixed and the Mfg. no longer supports this Graphics Card.

Bumping the "Importance" down to minor (from major).
Severity: major → minor
Is "GPU #2 Active" actually working? It's showing "false" for me even when I set Firefox to use the second GPU, and the GPU-indicator (part of the nVidia-driver) is showing that Firefox is using the second GPU.
"GPU #2 Active" doesn't really make a lot of sense, so having it in the troubleshooting is just confusing.  What would we expect to see?  For example, in a scenario where we have an integrated and a discrete GPU, when on a WebGL page, I may very well start using the discrete GPU, but when I switch to a simple text page, I won't need it anymore, so I may switch back to the integrated one.  The switching is dynamic, and based on the content on the page.  about:support is probably not the page that needs the high powered graphics, so switching to it to see what you're using would likely switch you back to the lower powered GPU.

We should probably just remove GPU #2 Active field all together.
You need to log in before you can comment on or make changes to this bug.