Firefox document.window reports incorrect values for narrow windows

UNCONFIRMED
Unassigned

Status

()

Firefox
General
UNCONFIRMED
6 years ago
5 years ago

People

(Reporter: mgol, Unassigned)

Tracking

7 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 559713 [details]
The bottom-right thumbnail is cut in half because of this bug.

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110909092210

Steps to reproduce:

I narrowed down Firefox window to a width so small that not the whole navigation toolbar fits in.


Actual results:

1) The whole navigation toolbar doesn't fit within the window.
2) Firefox stops recognizing the 'resize' event when lowering the window width even more.


Expected results:

Firefox shouldn't allow to narrow the window width to the value that not the whole toolbar fits in.

My few remarks: such a behaviour breaks CSS position: fixed property if sth is bound to the right edge of the window. Google Chrome & Opera just block resizing below value with which not all the toolbars would fit. IMHO Firefox should behave in a similar way.

One could think it's not worth it because the window would have to be very narrow to encounter this issue. That's not true; with the disappearance of status bar many add-ons moved their buttons to the navigation bar; for those which didn't it's still common to manually move the icons to the nav-bar. In this way, I found the issue occuring sometimes even at 600 pixels width or sth like that.
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110912 Firefox/9.0a1

Could you provide an example site/image that exhibits this issue when narrowing the Firefox window? As in the screenshot attachment.
I can't provide you with a real-site example as this is the project we're currently working on so I created a minimal test-case for you.
Ups, sorry, forgot to post the site address:

http://mgol.eu/asighsiergtuwreoktgwertgwerlktgewlrhgegeiwulrghliweirghwe
Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0

Thanks for the test case.

Could you please confirm I got the steps right:

1) Narrow down the Firefox window width to minimum value (from right to left or left to right)
2) Maximize the window again.

The problem should be that the image should be cut in half.

Correct behavior: the image should be displayed as normal.
Step 2 is not needed. Just unmaximize the window and then narrow the window width to a minimum value, you'll notice the image is being cropped from the right and it should *never* do that as it has the "position: fixed" (it was absolute but I changed it a moment ago as it's the way I do it in my project) and "right" properties set.
Is bug 687999 discussing the same issue as here?
Yep. The only additional remark is that it doesn't only clip UI toolbars, menus etc., but also page contents.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 687999
I'm changing it back to open since it definitely addresses a different problem than in bug 548777
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
The site I mentioned was launched some time ago so I can redirect you there:
http://norblin.bn.org.pl/fullscreen/103
This is a site based on Microsoft Seadragon technology (one can use mouse wheel to zoom in/out, drag the image with left mouse button), the added value are menus and the thumbnail interface (e.g. one can drag a visible rectangle from the thumbnail, making the whole image to move accordingly). Clipping window contents from the right side means the thumbnail gets hidden, making it difficult to operate on the site.
This problem doesn't happen on OS X to which I've recently switched. I am unable to assist further in this issue as I don't have an active Ubuntu instance any more.
You need to log in before you can comment on or make changes to this bug.