Turning webGL enabled makes HTML5's canvas blank

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: nblouveton, Unassigned)

Tracking

8 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:8.0a2) Gecko/20110905 Firefox/8.0a2
Build ID: 20110905071723

Steps to reproduce:

I went to about:config tab
I installed libosmesa6 on ubuntu 11.04
I entered "/usr/lib/libOSMesa.so.6" in webgl.osmesalib field
I checked that webgl.disabled was false
I tried to run this website : http://chrome.angrybirds.com/


Actual results:

The webpage is correctly loaded, game appears to start because it plays sounds, however the html5's canvas is blank.


Expected results:

When webgl is disabled, the game starts with audio/video contents.

Updated

7 years ago
Component: General → Canvas: WebGL
Product: Firefox → Core
QA Contact: general → canvas.webgl
This seems to be a OSMesa bug. I can reproduce it here. There is no WebGL warning.

Note that OSMesa doesn't seem to be very well maintained. The good news is that it shouldn't be needed: all latest Linux/Mesa drivers are enabled as of Firefox 7,
https://wiki.mozilla.org/index.php?title=Blocklisting/Blocked_Graphics_Drivers#On_X11

you can set webgl.force-enabled=true if your driver isn't force-enabled, and if you really want software rendering you should just use Mesa/llvmpipe.
WONTFIX because this is almost certainly a OSMesa bug and we can't do anything about it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.