Closed Bug 686245 Opened 8 years ago Closed 5 years ago

Intermittent Android "talosError: 'browser non-zero return code (1) [browser_output.txt]'"

Categories

(Testing :: Talos, defect)

ARM
Android
defect
Not set

Tracking

(firefox16 affected, firefox17 affected, firefox18 affected, firefox19 affected)

RESOLVED WORKSFORME
Tracking Status
firefox16 --- affected
firefox17 --- affected
firefox18 --- affected
firefox19 --- affected

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [for FF19 on Beta, see comment 1441][mobile_unittests][mobile_dev_needed])

Attachments

(1 file)

Talos is of the opinion that it's your fault you are returning 1, and you should be more explicit about what your problem was. Of course, you have no idea why you are, or how to reproduce it, but that's your problem, now isn't it?

https://tbpl.mozilla.org/php/getParsedLog.php?id=6372769
Android Tegra 250 mozilla-central talos remote-tpan on 2011-09-11 16:35:29 PDT for push 569a45bfb71c

RETURN:s: tegra-043
RETURN:id:20110911161228
RETURN:<a href = "http://hg.mozilla.org/mozilla-central/rev/569a45bfb71c">rev:569a45bfb71c</a>
tegra-043: 
		Started Sun, 11 Sep 2011 16:45:38
Running test tpan: 
		Started Sun, 11 Sep 2011 16:45:38
reconnecting socket
FIRE PROC: 'org.mozilla.fennec  -profile /mnt/sdcard/tests/profile http://bm-remote.build.mozilla.org/getInfo.html'
reconnecting socket
FIRE PROC: 'org.mozilla.fennec  -profile /mnt/sdcard/tests/profile http://bm-remote.build.mozilla.org/startup_test/fennecmark/fennecmark.html?test=PanDown%26webServer=bm-remote.build.mozilla.org'
reconnecting socket
pushing directory: /tmp/tmpAZX6ip/profile to /mnt/sdcard/tests/profile
	Screen width/height:1024/768
	colorDepth:24
	Browser inner width/height: 980/821

NOISE: __start_report137__end_report
NOISE: __startTimestamp1315759734736__endTimestamp
reconnecting socket
FIRE PROC: 'org.mozilla.fennec  -profile /mnt/sdcard/tests/profile http://bm-remote.build.mozilla.org/startup_test/fennecmark/fennecmark.html?test=PanDown%26webServer=bm-remote.build.mozilla.org'
NOISE: __start_report93__end_report
NOISE: __startTimestamp1315759916663__endTimestamp
reconnecting socket
FIRE PROC: 'org.mozilla.fennec  -profile /mnt/sdcard/tests/profile http://bm-remote.build.mozilla.org/startup_test/fennecmark/fennecmark.html?test=PanDown%26webServer=bm-remote.build.mozilla.org'
NOISE: __start_report99__end_report
NOISE: __startTimestamp1315760099158__endTimestamp
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
NOISE: 
NOISE: __FAILbrowser non-zero return code (1)__FAIL
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
Failed tpan: 
		Stopped Sun, 11 Sep 2011 16:59:31
FAIL: Busted: tpan
FAIL: browser non-zero return code (1)
Completed test tpan: 
		Stopped Sun, 11 Sep 2011 16:59:31
this is a clear sign the tegra is going away.  return code of '1' is not what the browser is returning, just which error handler in talos caught the error.  Some how we are causing the device to go offline, most likely by starving it of memory or killing off necessary processes (android does this when it is low on memory) and the network light goes off.
Whiteboard: [orange] → [orange][mobile_unittests][mobile_dev_needed]
https://tbpl.mozilla.org/php/getParsedLog.php?id=10259232&tree=Mozilla-Inbound
Whiteboard: [orange][mobile_unittests][mobile_dev_needed] → [orange][mobile_unittests][mobile_dev_needed][purple]
Duplicate of this bug: 740270
https://tbpl.mozilla.org/php/getParsedLog.php?id=11470740&tree=Mozilla-Inbound

Wonder how often robocheck2 actually manages to run.
https://tbpl.mozilla.org/php/getParsedLog.php?id=11504048&tree=Mozilla-Inbound

One in five or six times is how often robocheck2 runs, in case anyone else was curious.