Crash after loading midimap.dll - FF 6.0.2 over 140 Tabs open, can open using Aurora or Nightly

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Rob, Unassigned)

Tracking

({crash})

9 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 559825 [details]
WinDbg Log for bp-e01daa16-f420-49c8-80bf-6d9922110911 .

When I use TM+ with over 140 Tabs Firefox 6.0.2 crashes consistently. If I reload the same Session using Aurora or Nightly the Session can be reloaded easily.

I have: about:crashes bp-e01daa16-f420-49c8-80bf-6d9922110911 and am attaching a WinDbg log.


See also prior crash (no Log) for same reason: bp-8d853bae-61ce-4c50-a26a-5229f2110911


These were throttled:

5d729009-b686-49e2-abc0-b1d527e6ec1a	9/11/20110	9:54
080de685-66bf-4dc7-a0cb-e3a7e74c2ee3	9/11/20110	9:54
71a5d067-06a7-4696-ba43-94f58ca57a10	9/11/20110	9:53
758db8db-6a54-44aa-afd8-e4b84fdf7614	9/11/20110	9:53
57806470-3f1d-4b64-855f-c58a8d64bf36	9/11/20110	9:52
e995e03f-e427-47af-ae86-291e001e72fe	9/11/20110	9:52
841c3e33-551f-431e-8631-46eba593c618	9/11/20110	9:52



Refer to WinDbg Log. 
Started crashing here:

...
ModLoad: 648b0000 648c0000   C:\Documents and Settings\All Users\Application Data\Real\RealPlayer\BrowserRecordPlugin\ThinShims\rpnpshimswf.dll
eax=000000c0 ebx=0182cc20 ecx=00160200 edx=00000020 esi=000004d0 edi=00000000
eip=7c90e514 esp=0208ff2c ebp=0208ff90 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000246
ntdll!KiFastSystemCallRet:
7c90e514 c3              ret
1:059> g
DBGHELP: Symbol Search Path: srv*c:\symbols*http://symbols.mozilla.org/firefox;srv*c:\symbols*http://msdl.microsoft.com/download/symbols
DBGHELP: Symbol Search Path: srv*c:\symbols*http://symbols.mozilla.org/firefox;srv*c:\symbols*http://msdl.microsoft.com/download/symbols
DBGHELP: Symbol Search Path: srv*c:\symbols*http://symbols.mozilla.org/firefox;srv*c:\symbols*http://msdl.microsoft.com/download/symbols
DBGHELP: Symbol Search Path: srv*c:\symbols*http://symbols.mozilla.org/firefox;srv*c:\symbols*http://msdl.microsoft.com/download/symbols
DBGHELP: Symbol Search Path: srv*c:\symbols*http://symbols.mozilla.org/firefox;srv*c:\symbols*http://msdl.microsoft.com/download/symbols
DBGHELP: Symbol Search Path: srv*c:\symbols*http://symbols.mozilla.org/firefox;srv*c:\symbols*http://msdl.microsoft.com/download/symbols
Symbol search path is: SRV*c:\symbols*http://symbols.mozilla.org/firefox;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols;srv*
Executable search path is: 
DBGHELP: SharedUserData - virtual symbol module
ModLoad: 00400000 00406000   plugin-container.exe
ModLoad: 7c900000 7c9b2000   ntdll.dll
ModLoad: 7c800000 7c8f6000   C:\WINDOWS\system32\kernel32.dll
...


Firefox Window closed here:

...
ModLoad: 77bd0000 77bd7000   C:\WINDOWS\system32\midimap.dll
(1ee8.1f54): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=1010badc ebx=00000003 ecx=017c4730 edx=00000000 esi=00a6e800 edi=00000003
eip=5000ecc5 esp=0012a5e8 ebp=0012a5f4 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00210202
DBGHELP: logexts - public symbols  
         c:\symbols\logexts.pdb\BD91A4A4F22A45ABAE9974E5F934B7061\logexts.pdb
logexts!LogModuleSnapshot::GetModuleIndex+0x45:
5000ecc5 3b820c010000    cmp     eax,dword ptr [edx+10Ch] ds:0023:0000010c=????????
0:000> g
ModLoad: 77b40000 77b62000   C:\WINDOWS\system32\Apphelp.dll
DBGHELP: Symbol Search Path: srv*c:\symbols*http://symbols.mozilla.org/firefox;srv*c:\symbols*http://msdl.microsoft.com/download/symbols
...


Thanks,
Rob

Updated

7 years ago
Keywords: crash, crashreportid

Comment 1

7 years ago
> When I use TM+ with over 140 Tabs Firefox 6.0.2 crashes consistently. If I reload 
> the same Session using Aurora or Nightly the Session can be reloaded easily.

By this, do you mean they (Aurora or Nightly) start OK _with_ TM+?

If yes, 
- then I am confused as to why you would file this bug? 
(v7 is virtually out the door, and v6 won't be getting updates)
- And why is bug version set at v9?  
(the crash reports are v6)

first crash stack is 
0	logexts.dll	logexts.dll@0xecc5	
1	logexts.dll	logexts.dll@0x17e60	
2	logexts.dll	logexts.dll@0x33616	
3	xul.dll	xul.dll@0xc003c3	
4	xul.dll	xul.dll@0x10b8df	
5	xul.dll	NS_IsMainThread_P	obj-firefox/xpcom/build/nsThreadUtils.cpp:138
6	xul.dll	AbortIfOffMainThreadIfCheckFast	xpcom/base/nsCycleCollector.cpp:1195
7	xul.dll	nsXULElement::Release	content/xul/content/src/nsXULElement.cpp:391
8	xul.dll	nsCOMPtr_base::~nsCOMPtr_base	obj-firefox/dist/include/nsAutoPtr.h:969 

second is OOM
Severity: normal → critical
Crash Signature: [@ logexts.dll@0xecc5 ]
Keywords: crashreportid
(Reporter)

Comment 2

7 years ago
(In reply to Wayne Mery (:wsmwk) from comment #1)
> > When I use TM+ with over 140 Tabs Firefox 6.0.2 crashes consistently. If I reload 
> > the same Session using Aurora or Nightly the Session can be reloaded easily.
> 
> By this, do you mean they (Aurora or Nightly) start OK _with_ TM+?

* TM+ lets you save the 'list of Tabs' open (and their History).
* You can load the "list of Tabs" when you start Firefox ("Release"), Aurora, or Nightly, this allows you to resume your Browsing Session using any version of Firefox; you would do that so you can test all the versions (and also do whatever WORK you were doing - uninterrupted).
* There is a difference in the "Build" or a difference in the amount of Memory available between the three versions - Firefox "Release" ALWAYS can only load FEWER Tabs, Aurora or Nightly can ALWAYS load more Tabs; sometimes Aurora can load more than Nightly can and sometimes Nightly can load more than Aurora can BUT both can always load far more than the "Release" version ever can (except for over three years ago when they were approximately equal in this ability).


> If yes, 
> - then I am confused as to why you would file this bug? 
> (v7 is virtually out the door, and v6 won't be getting updates)
Six _might_ get Updates for "serious" problems (I think I am at 6.02 now, IE: I have had 2 Updates), it is a "serious" problem that the "Release" version supports only about 110 Tabs while the other version always support over 200 Tabs (and rarely over 300).

Even IF six is not to be updated the "Release" version 'always' (for the last two years, but not prior) supports far fewer Tabs than the 'development' versions - I think that is a Bug and do not want it to continue when "v7" goes "out the door".


> - And why is bug version set at v9?  
> (the crash reports are v6)
I _think_ that "fmdevelopertim@gmail.com" set that when he reviewed the Bug Report (see entry at "2011-09-12 16:42:19 PDT" (which does not have a 'Comment #')).

When I typed "about:crashes" into the URL Bar a Page comes up that allows you to click a Link to make a Bug Report (which brings you here). Perhaps Tim thinks it should be fixed in "Nightly" (v9) since the fixes go into Nightly and percolate down. 

Fix it in whichever version you wish BUT when the "Release" is made PLEASE let it operate with (way) more than ~100 Tabs (using TM+) (like Aurora and Nightly are able to do with ease). 

Restricting the "Release" versions (which is 6 now and will be 7 soon) to only be able to open so few Tabs affects people who save their History in open Tabs (for easy access and 'switching Hats').


Thanks for reading this Report Wayne.
(Reporter)

Comment 3

7 years ago
Firefox 7.01 ("Release", NOW) can open over well 200 Tabs (using TM+). 

Previously "Release" versions were only able to start (or restart) using TM+ with barely more than 100 Tabs in the "Session Restore" (depending upon each Tab's 'History Length' and possibly other Programs being ran at the same time).

I did not test if we can open more than 300 Tabs but I am satisfied with a more than doubling that the new "Release" version offers.

Closing as WFM in 7.01. (If someone wants it changed to "FIXED" (and to add a more specific version number) please feel free to change it, I don't have "FIXED" as a choice under "RESOLVED").


Thanks,
Rob
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.