Does not display background at http://thegunicorn.com

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: renangemignani, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1
Build ID: 20110831062634

Steps to reproduce:

Accessed http://thegunicorn.com


Actual results:

The background image was not shown, even though the page css shows:

body {
background: url("gunicorn-nowords-small.jpeg") 200 -50 no-repeat;
} 


Expected results:

The background image should have been shown, as is in Chromium or Opera.

Comment 1

7 years ago
CSS value should specify unit.
http://www.w3.org/TR/css3-values/#lengths

So I think this is the site issue.

Comment 2

7 years ago
> CSS value should specify unit.
MUST!

 url("gunicorn-nowords-small.jpeg") 200px -50px no-repeat;  works fine.

This is a bug in Webkit and Opera (I hoped these kind or bugs reports are gone...)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: General → Layout
OS: Linux → All
Product: Firefox → Core
QA Contact: general → layout
Hardware: x86_64 → All
Resolution: --- → INVALID
Version: 6 Branch → unspecified

Comment 3

7 years ago
BTW, Renan, thegunicorn.com is in quirksmode. This causes various incompatibilities between browsers.

You should trigger standards mode just by adding

<!DOCTYPE html>

on top of the HTML file. This avoids various problems, especially with Internet Explorer.
The key part is quirks mode.  In quirks browsers allow unitless lengths in various cases; we don't do that in shorthands because it makes the parsing ambiguous in some situations.  Looks like WebKit and Opera do allow them in shorthands sometimes...
You need to log in before you can comment on or make changes to this bug.