Message alert icon in system tray reports wrong number of new messages

RESOLVED DUPLICATE of bug 542725

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 542725
7 years ago
2 years ago

People

(Reporter: SyberTiger, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

6 Branch
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 559886 [details]
JPEG image of system tray message and image of email inbox

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110908135051

Steps to reproduce:

Received multiples emails (POP) using Thunderbird version 6.0.2.


Actual results:

In the system tray a "received message" icon appears to report received email messages.  The count of email messages is incorrect.


Expected results:

The system tray icon should indicate the number of new and unread messages sitting in the Thunderbird inbox.  Refer to the attached JPEG file that illustrates the problem.  In this particular example, when you right click (once) on the system tray message icon Thunderbird is reporting that one new message was received.  However, at the same time the information box (the top image in the attached JPEG file) shows the details as to the sender but is showing two sender IDs in that information box.  However, Thunderbird's inbox is showing four new and unread email messages (the bottom image in the attached JPEG file).
(Reporter)

Comment 1

7 years ago
Although there is evidence that there may have been the same bug or a similar bug in previous versions of Thunderbird I am reporting this as a new bug to version 6.0.2 as there is evidence that a similar bug in previous versions of Thunderbird as having been fixed.

Comment 2

7 years ago
(In reply to SyberTiger from comment #0)
If you received those new messages in different batches, then the number of new messages in the latest batch will be reported, not the total number of unread messages in all batches.

I'm Using the latest TB: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20110929 Thunderbird/7.0.1
Build ID: 20110929042316
Blocks: 36011
(Reporter)

Comment 3

7 years ago
(In reply to Hashem Masoud from comment #2)

If you take a look at the attached JPEG image from the original report you will see that the latest batch contains two (2) emails yst it says there is one (1) new message.  Study the JPEG image.  Note the timestamp of the two emails received.  Also, note the inconsistency of the system tray icon.

Comment 4

6 years ago
Looks similar to bug 542725.
Depends on: 542725

Updated

6 years ago
Component: General → Untriaged

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → Mail Window Front End
Resolution: --- → DUPLICATE
Duplicate of bug: 542725
You need to log in before you can comment on or make changes to this bug.