Closed Bug 686379 Opened 8 years ago Closed 8 years ago

Dragging to scroll preferences toggles checkmarks

Categories

(Firefox for Android Graveyard :: General, defect)

Firefox 9
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 9

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

(Keywords: regression)

Steps to reproduce:
1. Open the Fennec preferences.
2. Press on a check-mark row and slowly drag to scroll the settings list, keeping your finger on the same setting the whole time.
3. Release your finger.

Expected results: Checkmark does not change value.
Actual results: Checkmark value is toggled.

I believe this is a regression from bug 660686.
Duplicate of this bug: 686410
Backed out bug 660686:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e864670fad4e
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Whiteboard: [inbound]
Note: The backout also included the dependent bug 685147. (I pasted the wrong bug number in the commit message.)
https://hg.mozilla.org/mozilla-central/rev/e864670fad4e
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → Firefox 9
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110926
Firefox/9.0a1 Fennec/9.0a1
Device: Acer ICONIA A500
OS: Android 3.1
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.