add super double backup failsafe stronghold of bulletproofness to session restore

RESOLVED DUPLICATE of bug 883609

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 883609
6 years ago
4 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
According to SUMO feedback, users lose their session data. This reduces user trust in Firefox, which is unacceptable.

Thinking out loud:

We should implement a system of extra backups for session data, like we do for bookmarks. We should complement that with a system for validating session state at application start, relative to last known good state, and correct as necessary when discrepancies are found.

For example, we could keep copies of sessionstore.js each of the last X shutdowns.

Also at shutdown we could take some kind of signature of the data, and store it in a pref. At startup, we could compare the signatures and restore the last known good backup as necessary.
This sounds like a perfect candidate for a Firefox "feature". Are there any plans to get this on the roadmap for Firefox.next?
OS: Mac OS X → All
Hardware: x86 → All
I filed bug 558425 a while back for multiple copies of sessionstore.js/bak. That doesn't cover all of what you want, but it's a step in the right direction. Let's make this a tracking bug & we can hang bugs for more ideas off it.
Depends on: 558425
(Reporter)

Updated

6 years ago
Depends on: 701493

Comment 3

6 years ago
I had a local solution for this. My comments may be kinda late. Also, my suggested implementation may be slightly flawed, because I did not consider synchronizing the sessionstores with the Firefox accounts.

My idea is basically a timeline of sessionstore backups just like a nice backup service. Here is the original post:
https://bugzilla.mozilla.org/show_bug.cgi?id=660212#c5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 883609
You need to log in before you can comment on or make changes to this bug.