Rendering a table with rounded corners is very slow with hardware acceleration

RESOLVED DUPLICATE of bug 686634

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 686634
7 years ago
7 years ago

People

(Reporter: Luke Usherwood, Unassigned)

Tracking

7 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 560112 [details]
Offline page (.html and .css) showing slow table performance

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110908135051

Steps to reproduce:

A particular page containing a table with lots of cells performs very poorly when hardware acceleration is enabled. Scrolling by one page takes on the order of 400ms. Other actions have a similar delay: opening it, switching tabs; and when resizing the window it updates ~twice per second.

Without hardware acceleration there are no such delays, and it works fluidly.  My "from the armchair" hunch would be the rounded corners used in this table.

During these rendering 'glitches' firefox.exe doesn't show a considerable CPU usage. E.g. when resizing the window it averages about 30% of one CPU. (Hinting at graphics-memory delays or frequent locking??)

Reproduced in Firefox 4 through to most recent 7-Beta.

GRAPHICS (about:support):

Adapter Description: NVIDIA GeForce GTX 260
Vendor ID: 10de
Device ID: 05e2
Adapter RAM: 896
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2umDriver 
Version: 8.17.12.7533
Driver Date: 5-20-2011
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.17563)
GPU Accelerated Windows: 2/2 Direct3D 10
(Reporter)

Comment 1

7 years ago
Component -> Graphics
Component: General → Graphics
(Reporter)

Comment 2

7 years ago
Closing as Dup. Sorry folks. I hadn't noticed the Combo box had reset from Graphics to General after restarting firefox (to get the correct about:support text). I've resubmitted to make sure it goes to the right people.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686634
You need to log in before you can comment on or make changes to this bug.