Often, when entering a URL into the URL bar, and mouse slightly outside URL bar, feedback is slow or keystrokes are lost

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Alain Knaff, Unassigned)

Tracking

5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110622105737

Steps to reproduce:

Entered a URL in the URL bar, while the mouse was elsewhere in the firefox window.


Actual results:

Echo of my keystroke logo was slow, some keystrokes were lost


Expected results:

Either Firefox should not care where mouse is within its window, and treat URL normally.

Or it should care where it is, and have it not work at all if mouse is elsewhere.

But this in-between is needlessly annoying (took me a while to find out that it was related to exact mouse position)
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110914 Firefox/9.0a1

Typing in URL address bar works fine for me when mouse isn't hovering near the address bar.

Does the issue still occur if you start Firefox in Safe Mode or with a new profile?

http://support.mozilla.com/en-US/kb/Safe+Mode

http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 2

6 years ago
I noticed that it happens mostly if mouse happens to be over the bookmarks toolbar. If the mouse is elsewhere (such as over page contents), it doesn't seem to happen.

Unfortunately, as the problem is not 100% reproducible (it happens often, but only after having used firefox for a while), I could not (yet) determine whether it also happens in safe-mode.
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110914 Firefox/9.0a1

Firefox 6 was released. Have you tried upgrading to it and see if you can reproduce the issue?

As I can not reproduce, this is probably related to your user profile and the current . 

If you have any information to provide, please do so.
Version: 3.6 Branch → 5 Branch
(Reporter)

Comment 4

6 years ago
Sorry to not have gotten back to you earlier. I now tried it in 8.0, the issue is no longer present, which is good.

However, as I like to use extensions (such as HTML Validator), I've kept to 3.6.x on my home machine, and on that machine the issue is still present.

I still think the bug should be fixed in a version that supports extensions.

Comment 5

5 years ago
(In reply to Alain Knaff from comment #4)
> Sorry to not have gotten back to you earlier. I now tried it in 8.0, the
> issue is no longer present, which is good.

please close your bugs when not able to reproduce
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.