Thunderbird Filtering Engine Revolution

RESOLVED INVALID

Status

MailNews Core
Filters
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: ukrainianconsular, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110912 Firefox/9.0a1
Build ID: 20110912030829

Steps to reproduce:

Update Suggestions for the poor filtering Engine


Actual results:

I hope this will be implemented in next version


Expected results:

(New) Field      /   Condition    /  Match

To field Number / More than / (user defined number of e-mails ..)
Cc field Number / More than / (user defined number of e-mails ..)
(anything i select) / Is blank / (no need to enter anything here)
Image Url String / Starts or and Ends with /    /
Remote Inline Image / Is present / (no need to enter anything here)
/            /  Word starts with  /                   /
/            /  Word ends with   /                   /
Number of words excluding urls  / More than / (user defined number) /
Number of words excluding urls  / Less than / (user defined number) /
X-headers (User Defined Internet header field i can add here) /    /    /
                 


(New) Actions

Play sound (A way to browse the machine to add a file)
Print message
Reply with file & delete



Ps: *Important*, If a remote inline picture is present (even if i don't
select the new (Image Url String) rule, including every tags & the picture( s ),
& Excluding visual text that appears. The new (Is blank) condition remains positive.
So "Is blank" can contain remote inline pictures, the message should remain,
treated as blank .. .

New (Word starts with) & (Word ends with) condition's explanation:
The classic "Starts with" & "Ends with" always treated the beginning
of the body & end of the body, but not "ANY" word .. . As in the subject
field, it should affect any word & not the end or beginning of a line or
entire body .. .


4 important points:

1. A filter shouldn't be disabled because
there's ANY punctuation at the end of my
sentences (equals), or single words, UNLESS
i explicitly add a punctuation in the string,
then the punctuation is a "must have" .. .

2. The engine should detect if a rule already exists
(excluding rule names or rule combination's order)
& warn me before saving a new one, so i can simply
close the engine without saving it.

3. Words' Order, when aligned, must be respected
unless i enter a single word .. .

4. & for (Word starts with) & (Word ends with), many words
can be contained in respective Order, ex: best pil
either the body shows best pils or best pills or best pil$ .. .
Again: This treat a combination of words aligned & not
the entire body, like when people use (Starts with) &
(Ends with).


5. for (Number of words excluding urls), urls can either
be formatted or starting with: http



Kind regards.

Updated

6 years ago
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Version: 9 → unspecified

Comment 1

6 years ago
Reporter,

Thank you for your suggestions. I am closing this invalid because a bug report should request only one item.  http://quality.mozilla.org/docs/bugzilla/starter-kit/how-to-write-a-proper-bug/ will help explain.

Many of your items appear to relate to spam and junk messages.  If your main concern is junk processing, please be aware that it relies on bayesian filtering, and therefore does not score specific fields in specific ways. So it may be helpful to look at this reference http://kb.mozillazine.org/Junk_Mail_Controls and these related enhancement bug reports https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring&list_id=1300717&short_desc=bayes%20junk%20spam%20&field0-0-0=short_desc&bug_severity=enhancement&type0-0-1=substring&field0-0-1=keywords&type1-0-1=allwordssubstr&resolution=---&classification=Client%20Software&classification=Components&query_format=advanced&short_desc_type=anywordssubstr&type0-0-0=nowordssubstr&value0-0-0=news&component=Filters&field1-0-0=short_desc&product=MailNews%20Core&product=Thunderbird&field1-0-1=short_desc

THat said, traditional filters are not particularly well suited to being able to sift junk messages, although there are bug reports where people (like yourself) request such functionality.  You will find some of them in the list above, and in this larger list of filter enhancement bugs is https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring&list_id=1300719&field0-0-0=short_desc&bug_severity=enhancement&type0-0-1=substring&field0-0-1=keywords&type1-0-1=allwordssubstr&resolution=---&classification=Client%20Software&classification=Components&query_format=advanced&type0-0-0=nowordssubstr&value0-0-0=news&component=Filters&field1-0-0=short_desc&product=MailNews%20Core&product=Thunderbird&field1-0-1=short_desc

Please only comment in these bugs if you are able to contribute to fixing them.  Please create a new bug for any bugs which you find are not already reported.

Lastly, you might want to take a look at http://www.mesquilla.com/extensions/filtaquilla
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.