RESOLVED DUPLICATE of bug 666341

Status

RESOLVED DUPLICATE of bug 666341
7 years ago
6 years ago

People

(Reporter: Terry.F1Com, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The Download button and the +Downloading link do not direct the user to 3.6.22 but to 6.0.2.
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 666341
You need to log in before you can comment on or make changes to this bug.