Figure out how to make the installer be able to set Firefox as the default Internet browser without Windows confirming that decision in Windows 8

RESOLVED DUPLICATE of bug 760023

Status

()

Firefox
Installer
RESOLVED DUPLICATE of bug 760023
6 years ago
5 years ago

People

(Reporter: Away for a while, Unassigned)

Tracking

Trunk
x86
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Today when I installed Nightly on Windows 8 developer preview, I chose the option to make it the default browser (which is on by default).  When the installer was finished and I closed it, Windows prompted me which browser do I want to use by default, IE or Nightly, and I chose Nightly again.

I think we need to do something so that Windows doesn't try to re-confirm the user's choice as made inside the installer.
OS: Mac OS X → Other

Updated

6 years ago
OS: Other → Windows 8
I saw that too last night.

Does it still prompt if the user didn't check the "default" box during the install?
I assume this Windows default browser prompt is fine if the user doesn't set us as the default browser from the installer? Or do we want to supress it entirely?

I noticed that as soon as you steal focus away from that popup it disappears.  One possible way to do this task would be to have a tiny application run just to steal away focus and then close.  There are probably other ways though, like perhaps a registry tweak from the installer.
> Does it still prompt if the user didn't check the "default" box during the install?

Yes I just confirmed, it will prompt independent of the user selecting to use us as the default browser in the installer.
(Reporter)

Comment 4

6 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #2)
> I assume this Windows default browser prompt is fine if the user doesn't set
> us as the default browser from the installer? Or do we want to supress it
> entirely?

Yes, that should be fine.

> I noticed that as soon as you steal focus away from that popup it
> disappears.  One possible way to do this task would be to have a tiny
> application run just to steal away focus and then close.  There are probably
> other ways though, like perhaps a registry tweak from the installer.

That's a bit hackish, and might result in the window flickering and what-not.  We should first figure out if there is a supported way to get rid of this popup...

Comment 5

6 years ago
The registration requirements might have changed such that we don't support win8 fully and therefor cause this to be shown. I would say wait until the os is more finalized or until ms clarifies why this comes up.
> ehsan: That's a bit hackish, and might result in the window flickering...

> jimm: The registration requirements might have changed such that....

Good points, I agree. We should wait a bit on this, just wanted to have it posted with some ideas to track any extra info. Thanks for the insights.

Comment 7

6 years ago
(In reply to Jim Mathies [:jimm] from comment #5)
> The registration requirements might have changed such that we don't support
> win8 fully and therefor cause this to be shown. I would say wait until the
> os is more finalized or until ms clarifies why this comes up.

The user choice is now protected by a cryptographic hash.
If an application modifies the value programmatically (leaving the old hash), Windows will ignore the updated value.

We can simply remove the option from the installer, and Windows 8 will automatically display "You have new applications to open web pages. Click here to change your default program."

I think we should respect the user choice and simply let the OS manage the user preference.
I also think that is the best option for Windows 8.
Default related work is being tracked in bug 760023.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 760023
You need to log in before you can comment on or make changes to this bug.