Last Comment Bug 686778 - Web console: Move close button to the left on Mac
: Web console: Move close button to the left on Mac
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 9
Assigned To: (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
:
Mentors:
Depends on:
Blocks: 684561
  Show dependency treegraph
 
Reported: 2011-09-14 14:37 PDT by (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
Modified: 2011-09-21 04:53 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for bug (2.15 KB, patch)
2011-09-14 14:37 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
dcamp: review+
Details | Diff | Review
pre-patch screenshot (48.36 KB, image/png)
2011-09-15 11:00 PDT, Dão Gottwald [:dao]
no flags Details
Patch for bug 686778 v2 (1.17 KB, patch)
2011-09-18 14:51 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
jaws: review+
Details | Diff | Review

Description (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-09-14 14:37:32 PDT
Created attachment 560252 [details] [diff] [review]
Patch for bug

Bug 684561 moved the close button to the right on Windows but accidentally moved the close button to the right on Mac as well. Also some toolbarbutton margins that were increased on winstripe are also needed on gnomestripe.
Comment 1 Dão Gottwald [:dao] 2011-09-15 11:00:31 PDT
Created attachment 560404 [details]
pre-patch screenshot

Here's what the buttons look like for me on Linux without this patch. This looks ok to me, I don't think more space around them is needed.
Comment 2 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-09-18 14:51:01 PDT
Created attachment 560825 [details] [diff] [review]
Patch for bug 686778 v2

Removed the style changes for gnomestripe since it wasn't too terrible looking on gnomestripe pre-patch.

HUDService.jsm was r+ from dcamp whereas webconsole.css review was forwarded to dao. Therefore, I'll carry forward r+ from dcamp.
Comment 3 Rob Campbell [:rc] (:robcee) 2011-09-21 04:53:06 PDT
https://hg.mozilla.org/mozilla-central/rev/4866693ce45c

Note You need to log in before you can comment on or make changes to this bug.