moving a message out of the gmail trash folder moves message to Inbox

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
3 months ago

People

(Reporter: jorgevismara, Unassigned)

Tracking

6 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.12 Safari/535.2

Steps to reproduce:

moved a message (dragging it) from the trash to a folder 
(I'm using IMAP from Google Mail)


Actual results:

the message goes to the inbox instead


Expected results:

the message should appear in the folder I dragged it to
(In reply to jorgevismara from comment #0)
> moved a message (dragging it) from the trash to a folder 
> (I'm using IMAP from Google Mail)

Does the "trash" mean "[Gmail]/Trash" folder in Tb("Trash" at Gmail's Web Interface)?

If yes, or if "Display Language:" dependent localized folder name of "Trash" by Gmail, read 620323, please. See also for "move/copy mail to [Gmail]/Trash via gmail IMAP".

> the message should appear in the folder I dragged it to

Does it mean "the message did never appear in the folder you dragged it to"?
Or does it mean "the message should appear only in the folder you dragged it to"?
(Reporter)

Comment 2

7 years ago
I mean Gmail/trash... I'll check the 620323, thanks

about:
>> the message should appear in the folder I dragged it to

>Does it mean "the message did never appear in the folder you dragged it to"?
>Or does it mean "the message should appear only in the folder you dragged it to"?

as I describe in *actual results*, the message that was dragged to a folder, appeared in the inbox folder instead.  didn't show up in the folder where it was dragged into.
At which Folder pane view did you execute Drag&Drop of the mail?
"All Folders"? "Unified Folders"? Or other view such as "Favarite Folders"?
(Reporter)

Comment 4

7 years ago
I'm using  *All Folders* 

-- hold it, don't loose your time with this one...

I mean Gmail/trash... I'll check the 620323, thanks

about:
>> the message should appear in the folder I dragged it to

>Does it mean "the message did never appear in the folder you dragged it to"?
>Or does it mean "the message should appear only in the folder you dragged it to"?

as I describe in *actual results*, the message that was dragged to a folder, appeared in the inbox folder instead.  didn't show up in the folder where it was dragged into.

but WAIT... now doing more rigorous tests in TB 6, I see that the problem has to do with what was discussed in 620323...

hold it for the moment... looks like the issue ONLY happens when the message originally was in the INBOX, not if it was deleted from another folder... 

hold it, don't loose your time with this one...
xref to bug 620323 for ease of tracking and search.
Depends on: 620323

Comment 6

7 years ago
(In reply to WADA from comment #5)
> xref to bug 620323 for ease of tracking and search.

why is this not a duplicate?
Summary: moving a message out of the trash folder → moving a message out of the gmail trash folder moves message to Inbox
(In reply to Wayne Mery (:wsmwk) from comment #6)
> why is this not a duplicate?

Because next in comment #4 never occurs in that bug if ordinal environment.
> about:
> as I describe in *actual results*, the message that was dragged to a folder,
> appeared in the inbox folder instead.  didn't show up in the folder where it
> was dragged into.
If phenomenon of that bug, mail should appear in "the folder where it was dragged into", and in Inbox too if the mail had Gmail Label of "Inbox" before move/copy to Gmail/Trash.
(Reporter)

Comment 8

7 years ago
It happened again... moved/dragged a message from the trash to another folder, and ended up in the inbox. 
but I was not paying attention and don't remember the exact situation... found out later.

Comment 9

6 years ago
jorge, does this reproduce in version 17?
Flags: needinfo?(jorgevismara)
(Reporter)

Comment 10

6 years ago
it happens now... no changes since I posted my original message
Flags: needinfo?(jorgevismara)

Comment 11

3 months ago
Jorge wrote more recently "Actually have not [seen this] .... Made a couple of simulations and it is not happening any more..."
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.