NECKO: Apprunner restart chrash "illegal operation", cache and asp involved

VERIFIED INVALID

Status

()

P3
critical
VERIFIED INVALID
20 years ago
12 years ago

People

(Reporter: roger.larsson, Assigned: warrensomebody)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Trying to restart apprunner after this sequence will cause a chrash (at end)
clearing the cache will allow it to start ok again.

Version: 1999051808

(With a clean cache)
- Start apprunner.
- Let it load www.mozilla.org
- Go to www.3dfx.com
- Select: Europe->Products->Voodoo3 2000->"Voodoo3 2000 AGP/PCI Features"
  (now you should be at
    http://www.europe.3dfx.com/view.asp?IOID=80,
   along the way you will notice strange looking popups, see Bug #6856)
   Quiting here and reentering direct to page will not reproduce bug...!
- Select: V3 2000PCI UK Mirror 1 (twice, since nothing happens)
  Expected: Now a window to accept some licencing conditions should show up.
  Apprunner displays:
"Document http://www.europe.3dfx.com/view.asp?IOID=80 loaded successfully
Document: Done (0.27 secs)
Couldn't obtain menu item Forward
Couldn't obtain menu item Back
Error loading URL http://
Document: Done (0.28 secs)
Couldn't obtain menu item Forward
Couldn't obtain menu item Back
Error loading URL http://
"
- Closing main window, then the popup
- Restarting apprunner should crach
(But it does not when following this description,
 I have previously forced it twice... will check
 more but file this anyway)

I DO have a stored cache directory that fails(ed) :-)

Regards,
RogerL


APPRUNNER caused an invalid page fault in
module RAPTORGFXWIN.DLL at 014f:00a441ca.
Registers:
EAX=00a4e590 CS=014f EIP=00a441ca EFLGS=00010246
EBX=03316530 SS=0157 ESP=0078f100 EBP=0078f10c
ECX=00000000 DS=0157 ESI=0338d7d0 FS=11af
EDX=0338d2ec ES=0157 EDI=00000000 GS=0000
Bytes at CS:EIP:
8b 07 ff 50 18 89 45 08 db 45 08 d8 4e 3c d9 ee
Stack dump:
00000000 0338d7d0 03316530 0078f25c 0144823e 0338d7d0 00000000 00000087 000000c3
0331658c 03316530 033165e8 00000000 00000000 00000000 00000000
(Reporter)

Comment 1

20 years ago
Walking really slow now allowing each page to finish, but saw that the Products
page will never finish...(?). Walked true anyway. Now a restart craches :-> with
"APPRUNNER caused an invalid page fault in
module RAPTORGFXWIN.DLL at 014f:00a441ca."
(visual: Main window title "blank", white middle area, location frame, other
parts transparent)
[That's all for tonight]
/RogerL

Text in apprunner during never finishing load...
Document http://www.europe.3dfx.com/view.asp?PAGE=nusInterstitial1 loaded succes
sfully
Init!
adding "resource:/res/rdf/remote-flash-1.rdf" to the tree
an exception occurred trying to load "resource:/res/rdf/remote-flash-1.rdf":
Component returned failure code: 0x80004005 [nsIRDFXMLDataSource.Init, {file: fi
le:///E|/DEMOS/MOZILLA/BETA/BIN/res/rdf/flash.xul, line: 49}]
adding "resource:/res/rdf/remote-flash-2.rdf" to the tree
an exception occurred trying to load "resource:/res/rdf/remote-flash-2.rdf":
Component returned failure code: 0x80004005 [nsIRDFXMLDataSource.Init, {file: fi
le:///E|/DEMOS/MOZILLA/BETA/BIN/res/rdf/flash.xul, line: 49}]
adding "resource:/res/rdf/remote-flash-3.rdf" to the tree
an exception occurred trying to load "resource:/res/rdf/remote-flash-3.rdf":
Component returned failure code: 0x80004005 [nsIRDFXMLDataSource.Init, {file: fi
le:///E|/DEMOS/MOZILLA/BETA/BIN/res/rdf/flash.xul, line: 49}]
Document: Done (361.58 secs)
Couldn't obtain menu item Forward
Couldn't obtain menu item Back
Error loading URL http://www.europe.3dfx.com/view.asp?PAGE=nusEuropeHome

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M8

Comment 2

20 years ago
Pushed past necko landing...

Updated

20 years ago
Summary: Apprunner restart chrash "illegal operation", cache and asp involved → NECKO: Apprunner restart chrash "illegal operation", cache and asp involved
Target Milestone: M9 → M10

Comment 3

20 years ago
Deferred till caching works in Necko.

Updated

20 years ago
Blocks: 14050

Updated

20 years ago
Target Milestone: M10 → M12

Comment 4

20 years ago
Deferring till cache lands. CC'ng fur.

Comment 5

20 years ago
Moving Assignee from gagan to warren since he is away.
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → INVALID
(Assignee)

Comment 6

20 years ago
Old nu cache. Invalid.

Comment 7

20 years ago
Bulk move of all Cache (to be deleted component) bugs to new Networking: Cache
component.

Comment 8

19 years ago
Sorry for the spam, changing QA contact.
QA Contact: paulmac → tever

Comment 9

19 years ago
marking verified per Warren's comment
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.