All users were logged out of Bugzilla on October 13th, 2018

outdated display of message while loading

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: tilman, Unassigned)

Tracking

7 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

Click on a message header


Actual results:

A different message was shown, while the "real" message was loading


Expected results:

A blank screen should have been shown, or a text "your message is loading".

This effect isn't really new, but it is bothering me a lot because when I am using slow networks while travelling. This has been happening for a long time, I believe since version 3 or even earlier. It is easy to reproduce when you have a slow network, or a message with a huge attachment. (I am using IMAP)
(Reporter)

Comment 1

7 years ago
To clarify: with "a different message", I mean "a previously displayed message". 
I am NOT alleging that TB is mixing up messages.
This has happened for years both with XP and Windows 7. More detailed steps to reproduce:
- display message list full screen
- double click on message
- message is displayed
- close it
- double click on different message
- previous message is displayed until new message is downloaded, which can take from a fraction of a second to several minutes.

Comment 2

7 years ago
(In reply to Tilman from comment #1)
> To clarify: with "a different message", I mean "a previously displayed
> message". 
Agreed. There is some lag between displaying previous and current emails.
User agent: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20110929 Thunderbird/7.0.1
Build ID: 20110929042316

Comment 3

7 years ago
(In reply to Tilman from comment #1)
Of course, this also depends on the content of the new message being displayed (text is rendered faster than HTML) and your PC/laptop specs.
Whiteboard: dupme
(Reporter)

Comment 4

3 years ago
I suspect that the bug has been fixed some time ago... I just realize the effect is no longer happening for me.
Closing this bug according to reporter's latest comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.