Open Bug 686975 Opened 8 years ago Updated 8 years ago

Restore view source

Categories

(Firefox :: Menus, defect)

x86
macOS
defect
Not set

Tracking

()

People

(Reporter: brett, Unassigned)

Details

I believe moving "View>Source" to "Web Developer>Page Source" is a mistake.

I've created an etherpad in the hopes of gathering more voices to support me in this.

I appreciate the desire to streamline the browser.  The text below sums up why I think we should have the option to view the source of a web page made as simple as possible.

Thanks for listening!
Brett

http://etherpad.mozilla.com:9000/restoreviewsource
Don't forget that the Firefox button on Windows / Linux (when no menubar is shown) doesn't have a View menu at all, you have to be careful not to widen the platform differences. And there's also the desire to hide all techie things, in this case under the Web Developer menu.
That's my point though, Jo.  By "hiding techie things" we're discouraging this discovery.  I understand why the choices were made, I just don't agree with them and thought I should speak up :)

I think View Source could be a top level menu item, even in Windows and other platforms where the firefox menu has replaced the view menu.  I think it is as important to our mission as Sync, for example.
While I understand and respect what Brett is suggesting, I also believe that this bug should be resolved WONTFIX.

There is an actual cost to placing menu items in front of a user, as defined by Hick's Law (http://en.wikipedia.org/wiki/Hick%27s_law). Every additional menu item makes it more costly (in terms of time) and harder to choose the appropriate menu item. The goal of the new Firefox Menu on the Windows platform was to simplify the top-level menu items to the most frequently used functions [1] and allow drill downs to secondary commands.

While I agree that View Source is a laudable feature to have and would never support its removal or being made an option, placing it in a submenu is *not* a regression - it had always been in a submenu before. Perhaps indeed "Web Developer" is too daunting a title for "View Source" and its kin; perhaps "Tools" would be a better name for that group of functions. However, it's never been a top-level feature for Firefox, nor do I believe it should be despite the direct relation to mission. Put plainly: while we want it to be easy for people to view the source, we want it to be easier for people to *use* the web, and viewing the source isn't part of that. It is a mistake to assert that we believe all web users should become web builders, and to forget that Firefox is first and foremost a product aimed at consumers and web *users* [2]

[1]: whether or not Sync Now has a place at this top level is worthy of debate, but not in conjunction with this issue

[2]: yes, we want users to become builders, but the way to do that is not to create a product that is more complex to use
OS: Mac OS X → All
Oh, I should also mention (and cc!) the UX team. I know that this was not done absent-mindedly, and recall the team thinking long and hard about moving this particular command when doing the Windows menu reworking.
Also, right-click->view page source is pretty quick. I find the menu placement super-irksome as well - I like it exposed - but right clicking on the page content and selecting view source is faster than both the menu options (I find).
@beltzner: again, my point is that this speaks directly to Mozilla's mission. It should trump the desire to streamline the menus.

Also, I think in this case, Hicks law works in my argument's favour. If a person who doesn't know the web is malleable must first choose to consider whether or not they are a web developer (or curious about this), then the odds of them revealing the source of the page diminish.

@kev: You already know you want to view the source of a page, so right-click>view source works for you.  This bug is about moving view source from a developer-centric placement to one that all users can find.
OS: All → Mac OS X
(In reply to Brett Gaylor from comment #6)
> @beltzner: again, my point is that this speaks directly to Mozilla's
> mission. It should trump the desire to streamline the menus.

And my point is that while Mozilla is a mission-oriented organization, Firefox is a consumer-oriented product. We have this debate a lot (and with good cause!) when determining which technologies to support (see: h.264, WebM) but when it comes to the user interface, user interaction efficiency must trump.

The simple truth is that of any population, it is a subset who are builders and interested in understanding the mechanism's workings. While I think it would be cool, search engines do not place a "Why am I seeing this result?" next to every entry on a search results page - it's simply not relevant to most people, they're just interested in the result. Similarly, the majority of our hundreds of millions of users are interested in the effect of the page, not the source upon which it is based.

By no means (as stated above) would I ever want to see this feature marginalized or removed - but I don't think it deserves to be elevated and placed in the line of sight of all of our users. Further, I think View Source is decreasingly useful as a "how is this web page built?" tool especially as compared to something like the more interactive Web Console or Inspector tools -- why would we elevate the less usable option, if we were to elevate one at all?

> Also, I think in this case, Hicks law works in my argument's favour. If a
> person who doesn't know the web is malleable must first choose to consider
> whether or not they are a web developer (or curious about this), then the
> odds of them revealing the source of the page diminish.

You're misunderstanding Hick's Law - it simply dictates that adding choices means that the choice is made more difficult and time consuming. Nothing about the content of those choices ... just about how there is a cost to every single item in that menu, when considering user interface efficiency.
>> adding choices means that the choice is made more difficult and time consuming. 

Exactly.  Do you choose to be a web developer, or do you notice this ability to view the source of a web page?  Throw that choice at them, and the cost is fewer people understanding how the web works.

I'm the first to admit I'm way outside of my domain expertise, here. I just think this should be really easy to find in our browser and lay people should be encouraged to click it :)

I imagine, being smart folks, there was a lot of discussion about whether to move this item among the UX team.  And yes, I've heard the stories of people writing SUMO because they thought they had a virus when they accidentally viewed the source.  

I think that this particular item needs special attention.  It has costs of its own, the same as perceived speed etc.
Is there a conflict in Mozilla's mission? http://www.mozilla.org/about/mission.html
"creating great software" versus "give people tools to take control of their online lives".

If you (Mozilla) think further in this direction of simplifying the menus to the max you might as well remove the whole "Web Developer" menu and let developers get it back by installing a web development addon. (Shudder)

The browser is not a mere tool to enable online shopping.

I agree that great software should be easy to use but the View Source should stay where it is. To control your online live people need to understand (to a degree) how the web works.
The View menu is going away, so there is no way to "leave View Source where it is."

There is no conflict in Mozilla's mission, there are decisions to be made about how best to accomplish it. Observably Mozilla's mission has benefit *directly* from the consumer success of Firefox, moreso than any other single initiative. There have been numerous times when the mission has prevented certain technologies (ActiveX, h.264) from being included with the consumer product, and times when the goals of the consumer product have overridden mission-oriented features (DOM Inspector, some of the advanced Page Info tools, HTML Editor).

Please let's not make a mountain out of a molehill, here. This is not a cut and dry choice, it's a request by Brett to make View Source more prominent in our UI than it used to be, and a response by a former product driver expressing caution.
The move (just focusing on the traditional menu bar) was based on the following assumptions:

-We are creating a wide range of web developer tools consisting of many menu entries, and we want them to be all grouped together so you discover the full set

-anyone curious and exploring will be better served with the range of tools (like inspector, highlighter, etc. since they have a much stronger educational value than simply the raw text of the source)

-we can't place all of these tools at the top level, because proportionally they just aren't relevant to 99% of our users.  We agree that the 1% that actually builds the Web is super important, but we didn't remove the tools, we just placed them together in a sub-menu.

-overall right clicking on the page is a more direct and discoverable way to view the source (or inspect element) compared to the traditional menu bar, regardless of where we place the command in the traditional menu bar
You need to log in before you can comment on or make changes to this bug.